summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-03-17 18:24:17 +0100
committertytan6522024-03-17 18:24:17 +0100
commit6bd7afeac4ae85f1481e5a356005d42f1719214e (patch)
tree9bc4a9d86ff99d06d142032193bafaab0ff03f45
parentebbe0cf79c353a34b0c722148ecb7dc32b030eb9 (diff)
downloadaur-6bd7afeac4ae85f1481e5a356005d42f1719214e.tar.gz
build: Allow deprecation for future-proofing
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 723592ddfbad..f477e81f1103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Add a Downstream Keyer dock to OBS studio"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/downstream-keyer.1254/"
-license=("GPL2")
+license=("GPL-2.0-or-later")
depends=("obs-studio>=30" "gcc-libs" "glibc" "qt6-base")
makedepends=("cmake" "git")
source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=9c2005483e0b4b2a220a517e33eb8e4bfabd1320")
@@ -18,7 +18,9 @@ build() {
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6
+ -DQT_VERSION=6 \
+ -DCMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations" \
+ -Wno-dev
cmake --build build
}