summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2019-09-25 10:39:18 +0200
committerRichard Neumann2019-09-25 10:39:18 +0200
commit3d15af662a2727552d33e74f8be7b4072d371efc (patch)
tree298575f3aba276f789675104652936cbaa4a37e9
parent8171e8158a0dab7e697141a842bb28d13b86e0d8 (diff)
downloadaur-3d15af662a2727552d33e74f8be7b4072d371efc.tar.gz
Refactored PKGBUILD.
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0653bdbf0a72..6025d2c7fce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,11 @@ sha256sums=('f452670c0ffee3b08296370e7cfe6ac2b442588942b96c78e0b1bf05f09b6e49')
build() {
- cd "${pkgname}-${pkgver}"
- meson --buildtype=release build
- ninja -C build
+ meson --buildtype=release --prefix=/usr "${pkgname}-${pkgver}" "${pkgname}-${pkgver}/build"
+ ninja -C "${pkgname}-${pkgver}/build"
}
package() {
- install -Dm 644 "${pkgname}-${pkgver}/build/gnome-screencast.so" "${pkgdir}/usr/lib/obs-plugins/gnome-screencast.so"
+ DESTDIR="${pkgdir}" ninja -C "${pkgname}-${pkgver}/build" install
}