summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-30 09:43:10 +0200
committertytan6522022-09-30 09:43:10 +0200
commit05a654f498a013dc17119102449e6d27fd6cc2f5 (patch)
treee0f7d64126b22ef41bc66b0b4d1189b577b8fc9b
parentdc9ae6c87588105d36203371a13b280cbdfe5090 (diff)
downloadaur-obs-gphoto.tar.gz
build: Fix build with OBS 28
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe9df49cf3af..ca779ccc7b56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-gphoto
pkgdesc = Allows connect DSLR cameras with obs-studio through gPhoto on Linux
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/maaleske/obs-gphoto
arch = i686
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = obs-gphoto
makedepends = cmake
makedepends = git
makedepends = libcaption
- depends = obs-studio
+ depends = obs-studio>=28
depends = libgphoto2
source = obs-gphoto-0.5.0.tar.gz::https://github.com/maaleske/obs-gphoto/archive/v0.5.0.tar.gz
sha256sums = 6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7
diff --git a/PKGBUILD b/PKGBUILD
index c26fe6d28898..4aa35f0ab780 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,23 @@
pkgname=obs-gphoto
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Allows connect DSLR cameras with obs-studio through gPhoto on Linux"
arch=("i686" "x86_64" "aarch64")
url="https://github.com/maaleske/obs-gphoto"
license=("GPL2")
-depends=("obs-studio" "libgphoto2")
+depends=("obs-studio>=28" "libgphoto2")
makedepends=("cmake" "git" "libcaption")
source=("$pkgname-$pkgver.tar.gz::https://github.com/maaleske/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=("6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7")
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ sed -i 's/LibObs/libobs/' CMakeLists.txt
+ sed -i 's/${LIBOBS_LIBRARIES}/OBS::libobs/' CMakeLists.txt
+}
+
build() {
cd "$pkgname-$pkgver"