summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAeternus Atterratio2017-10-22 21:54:00 +0300
committerAeternus Atterratio2017-10-22 21:54:00 +0300
commit107f68ad0d6c1e55eaf7fc5f2717513ed81cc897 (patch)
treed646e481c762496a1809fc73b7cc4a625741a6c3
downloadaur-107f68ad0d6c1e55eaf7fc5f2717513ed81cc897.tar.gz
Upload v0.2.0 of my obs-studio plugin
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2200d7f3851c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = obs-gphoto
+ pkgdesc = Allows connect DSLR cameras with obs-studio through gPhoto on Linux
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/Atterratio/obs-gphoto
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = obs-studio
+ depends = libgphoto2
+ depends = imagemagick
+ source = https://github.com/Atterratio/obs-gphoto/archive/v0.2.0.tar.gz
+ sha256sums = a7dc2ea88b066e2c39f3e3f09af43864c96d057f047de7de3c917ec77209e0e0
+
+pkgname = obs-gphoto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71af3bbe0957
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Atterratio
+pkgname=obs-gphoto
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Allows connect DSLR cameras with obs-studio through gPhoto on Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/Atterratio/obs-gphoto"
+license=("GPL2")
+depends=("obs-studio" "libgphoto2" "imagemagick")
+makedepends=("cmake")
+source=("https://github.com/Atterratio/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=("a7dc2ea88b066e2c39f3e3f09af43864c96d057f047de7de3c917ec77209e0e0")
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cmake . -DSYSTEM_INSTALL=1
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir}/ install
+}
+