summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-10-27 13:28:26 +0200
committertytan6522021-10-27 13:28:26 +0200
commitdc9ae6c87588105d36203371a13b280cbdfe5090 (patch)
tree419f945d57540409b1e9e982305a05a4668be54b
parent49790654abb6dc6fa8b0ebf12103b63c17dd01d3 (diff)
downloadaur-dc9ae6c87588105d36203371a13b280cbdfe5090.tar.gz
build: Cleanup
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc23ea81d81b..fe9df49cf3af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-gphoto
pkgdesc = Allows connect DSLR cameras with obs-studio through gPhoto on Linux
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/maaleske/obs-gphoto
arch = i686
arch = x86_64
@@ -9,12 +9,10 @@ pkgbase = obs-gphoto
license = GPL2
makedepends = cmake
makedepends = git
- depends = obs-studio>=27.0.0
+ makedepends = libcaption
+ depends = obs-studio
depends = libgphoto2
- depends = libcaption
source = obs-gphoto-0.5.0.tar.gz::https://github.com/maaleske/obs-gphoto/archive/v0.5.0.tar.gz
- source = obs-studio-27.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.0.0.tar.gz
sha256sums = 6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7
- sha256sums = c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e
pkgname = obs-gphoto
diff --git a/PKGBUILD b/PKGBUILD
index 2113b85772a2..c26fe6d28898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,32 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
+# Contributor: Atterratio
+# Contributor: Omar Pakker <archlinux@opakker.nl>
+
pkgname=obs-gphoto
pkgver=0.5.0
-_obsver=27.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Allows connect DSLR cameras with obs-studio through gPhoto on Linux"
arch=("i686" "x86_64" "aarch64")
url="https://github.com/maaleske/obs-gphoto"
license=("GPL2")
-depends=("obs-studio>=$_obsver" "libgphoto2" "libcaption")
-makedepends=("cmake" "git")
-source=(
- "$pkgname-$pkgver.tar.gz"::"https://github.com/maaleske/$pkgname/archive/v$pkgver.tar.gz"
- "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
-)
-sha256sums=(
- "6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7"
- "c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e"
-)
+depends=("obs-studio" "libgphoto2")
+makedepends=("cmake" "git" "libcaption")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/maaleske/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=("6f1303582ea89f2f3203f86620ff5aeba66b5c83a8924c69e648845ae9fe2ba7")
build() {
cd "$pkgname-$pkgver"
+
cmake -B build \
- -DLIBOBS_INCLUDE_DIR=../obs-studio-$_obsver/libobs \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DSYSTEM_INSTALL=1
+
make -C build
}
package() {
cd "$pkgname-$pkgver"
+
make -C build DESTDIR="$pkgdir/" install
}