summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-03-17 18:43:33 +0100
committertytan6522024-03-17 18:43:33 +0100
commitba23c10d1096f0ebd6898d690d87cba206897875 (patch)
tree8780dc90dfcaa27cc544fa2f08f314fee65783b5
parente468679ad67416f4cc09e7babeed84fece2c2fde (diff)
downloadaur-ba23c10d1096f0ebd6898d690d87cba206897875.tar.gz
build: Allow deprecation for future-proofing
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 256afaa23b39..97ae8f778f87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = obs-gradient-source
url = https://obsproject.com/forum/resources/gradient-source.1172/
arch = x86_64
arch = aarch64
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = cmake
makedepends = git
depends = obs-studio>=28
diff --git a/PKGBUILD b/PKGBUILD
index d4db0df43212..8e9a86546811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,19 @@ pkgrel=1
pkgdesc="Gradient Source for OBS studio"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/gradient-source.1172/"
-license=("GPL2")
+license=("GPL-2.0-or-later")
depends=("obs-studio>=28" "glibc")
makedepends=("cmake" "git")
source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=70c0ed3ba1763692dfafcd28328fdf29c497b92d")
sha256sums=('SKIP')
-prepare()
-{
- cd "$pkgname"
- sed -i "s|-Wswitch|-Wswitch -Wno-error=format-truncation|" cmake/ObsPluginHelpers.cmake
-}
-
build() {
cmake -B build -S $pkgname \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
+ -DCMAKE_C_FLAGS="-Wno-error=deprecated-declarations -Wno-error=format-truncation" \
-Wno-dev
cmake --build build