summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-10-14 23:35:39 -0400
committerzan2020-10-14 23:35:39 -0400
commit8423b389f68305e0943d69f66d955a1c94b0e248 (patch)
tree3ff12908a7f174faa55672c1a043a69efd19704d
parent3f65603fc468e50f608260f84e900181deadc6db (diff)
downloadaur-8423b389f68305e0943d69f66d955a1c94b0e248.tar.gz
fix diff
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--hevc-vaapi.diff16
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8990f4732fe5..a720ed6f741b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-hevc-vaapi-git
pkgdesc = Free and open source software for video recording and live streaming. With VAAPI HEVC support.
- pkgver = 26.0.1.r5.g3486c0b36
+ pkgver = 26.0.2.r25.g0b24b3ae1
pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = i686
@@ -30,7 +30,7 @@ pkgbase = obs-hevc-vaapi-git
optdepends = luajit: Lua scripting
optdepends = python: Python scripting
optdepends = qt5-svg: svg support
- provides = obs-studio=26.0.1.r5.g3486c0b36
+ provides = obs-studio=26.0.2.r25.g0b24b3ae1
conflicts = obs-studio
source = obs-hevc-vaapi-git::git+https://github.com/obsproject/obs-studio.git
source = git+https://github.com/Mixer/ftl-sdk.git
@@ -39,7 +39,7 @@ pkgbase = obs-hevc-vaapi-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = f01073324e2a83f0925bc19902d3ce19835b445820d57ad531eb8f3ebbb53266
+ sha256sums = 66fed73be753773fb52f98fdb92b37353e0450653125007e8ab694e97983a71b
pkgname = obs-hevc-vaapi-git
diff --git a/PKGBUILD b/PKGBUILD
index b9050f4944fc..155cad158377 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer zan <zan@420blaze.it>
pkgname=obs-hevc-vaapi-git
-pkgver=26.0.1.r5.g3486c0b36
+pkgver=26.0.2.r25.g0b24b3ae1
pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming. With VAAPI HEVC support."
arch=(i686 x86_64)
@@ -24,7 +24,7 @@ source=("$pkgname::git+https://github.com/obsproject/obs-studio.git"
"git+https://github.com/obsproject/obs-browser.git"
"hevc-vaapi.diff")
sha256sums=("SKIP" "SKIP" "SKIP"
- "f01073324e2a83f0925bc19902d3ce19835b445820d57ad531eb8f3ebbb53266")
+ "66fed73be753773fb52f98fdb92b37353e0450653125007e8ab694e97983a71b")
pkgver() {
cd $pkgname
diff --git a/hevc-vaapi.diff b/hevc-vaapi.diff
index 77a121156b98..d0bfd0cd6464 100644
--- a/hevc-vaapi.diff
+++ b/hevc-vaapi.diff
@@ -1,15 +1,15 @@
diff --git a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
-index 8b9c0f243..d39291389 100644
+index b9a43e5de..06a04658b 100644
--- a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
+++ b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
-@@ -547,17 +547,14 @@ static inline int open_output_file(struct ffmpeg_mux *ffm)
+@@ -610,17 +610,14 @@ static inline int open_output_file(struct ffmpeg_mux *ffm)
}
ret = avformat_write_header(ffm->output, &dict);
+ av_dict_free(&dict);
if (ret < 0) {
- fprintf(stderr, "Error opening '%s': %s\n", ffm->params.file,
- av_err2str(ret));
+ fprintf(stderr, "Error opening '%s': %s",
+ ffm->params.printable_file.array, av_err2str(ret));
- av_dict_free(&dict);
-
@@ -299,10 +299,10 @@ index ee5829678..3475efef7 100644
#endif
diff --git a/plugins/obs-ffmpeg/obs-ffmpeg.c b/plugins/obs-ffmpeg/obs-ffmpeg.c
-index 38a7c8573..03b270e99 100644
+index 5a9a3e06b..df9e41ba6 100644
--- a/plugins/obs-ffmpeg/obs-ffmpeg.c
+++ b/plugins/obs-ffmpeg/obs-ffmpeg.c
-@@ -34,6 +34,7 @@ extern struct obs_encoder_info nvenc_encoder_info;
+@@ -35,6 +35,7 @@ extern struct obs_encoder_info nvenc_encoder_info;
#ifdef LIBAVUTIL_VAAPI_AVAILABLE
extern struct obs_encoder_info vaapi_encoder_info;
@@ -310,7 +310,7 @@ index 38a7c8573..03b270e99 100644
#endif
#ifndef __APPLE__
-@@ -208,9 +209,9 @@ finish:
+@@ -209,9 +210,9 @@ finish:
#endif
#ifdef LIBAVUTIL_VAAPI_AVAILABLE
@@ -322,7 +322,7 @@ index 38a7c8573..03b270e99 100644
return !!vaenc;
}
#endif
-@@ -250,10 +251,14 @@ bool obs_module_load(void)
+@@ -252,10 +253,14 @@ bool obs_module_load(void)
obs_register_encoder(&nvenc_encoder_info);
}
#if !defined(_WIN32) && defined(LIBAVUTIL_VAAPI_AVAILABLE)