summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNexAdn2017-11-06 16:15:19 +0100
committerNexAdn2017-11-06 16:15:19 +0100
commitf056132fcb5dd63d69f8560f626191cd8c76eb32 (patch)
treefd9e4559fd107897c5c2e1e939a59fc7590b0e72
parent7c4b7a1508e34c5596d9aaeab83f3608355d8fc1 (diff)
downloadaur-f056132fcb5dd63d69f8560f626191cd8c76eb32.tar.gz
Version 3.202
Signed-off-by: NexAdn <nexadn@yandex.com>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90d2e7d69c7e..94505b70f871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cef-minimal
pkgdesc = Chromium Embedded Framework minimal release
- pkgver = 3.3071
- pkgrel = 1
+ pkgver = 3.3202
+ pkgrel = 2
url = https://bitbucket.org/chromiumembedded/cef
arch = i686
arch = x86_64
@@ -10,19 +10,15 @@ pkgbase = cef-minimal
makedepends = make
depends = nss
depends = alsa-lib
- depends = atk
depends = gconf
- depends = pango
- depends = libxrandr
- depends = libxcursor
depends = libxss
depends = libxtst
- depends = libxcomposite
depends = gtk2
- source_i686 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3071.1649.g98725e6_linux32_minimal.tar.bz2
- sha1sums_i686 = 28f83276ced6e957645ad54fb318e1a0fb063a6b
- source_x86_64 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3071.1649.g98725e6_linux64_minimal.tar.bz2
- sha1sums_x86_64 = bf554a5c19e18aac5ab8f2c4ba9247f4d738e221
+ provides = cef
+ source_i686 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3202.1681.g9672a06_linux32_minimal.tar.bz2
+ sha1sums_i686 = 7f7fb1df2337b3a117dc186b740eac380680028c
+ source_x86_64 = http://opensource.spotify.com/cefbuilds/cef_binary_3.3202.1681.g9672a06_linux64_minimal.tar.bz2
+ sha1sums_x86_64 = bde2f9193bddd992d60311770d7bef7c5e942898
pkgname = cef-minimal
diff --git a/PKGBUILD b/PKGBUILD
index 37a8514c30f9..d3aebc85f0c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer: NexAdn <nexadn@yandex.com>
pkgname=cef-minimal
-pkgver=3.3071
-_subver_i686=1649.g98725e6
-_subver_x86_64=1649.g98725e6
-pkgrel=1
+pkgver=3.3202
+_subver_i686=1681.g9672a06
+_subver_x86_64=${_subver_i686}
+pkgrel=2
pkgdesc="Chromium Embedded Framework minimal release"
arch=("i686" "x86_64")
url="https://bitbucket.org/chromiumembedded/cef"
license=("BSD")
-depends=("nss" "alsa-lib" "atk" "gconf" "pango" "libxrandr" "libxcursor" "libxss" "libxtst" "libxcomposite" "gtk2")
+depends=("nss" "alsa-lib" "gconf" "libxss" "libxtst" "gtk2")
makedepends=("cmake" "make")
+provides=("cef")
source_i686=(
"http://opensource.spotify.com/cefbuilds/cef_binary_${pkgver}.${_subver_i686}_linux32_minimal.tar.bz2"
)
source_x86_64=(
"http://opensource.spotify.com/cefbuilds/cef_binary_${pkgver}.${_subver_x86_64}_linux64_minimal.tar.bz2"
)
-sha1sums_i686=(
- "28f83276ced6e957645ad54fb318e1a0fb063a6b"
-)
-sha1sums_x86_64=(
- "bf554a5c19e18aac5ab8f2c4ba9247f4d738e221"
-)
+sha1sums_i686=('7f7fb1df2337b3a117dc186b740eac380680028c')
+sha1sums_x86_64=('bde2f9193bddd992d60311770d7bef7c5e942898')
[[ "$CARCH" = "i686" ]] && _arch="32" && _subver=$_subver_i686
[[ "$CARCH" = "x86_64" ]] && _arch="64" && _subver=$_subver_x86_64
build() {
@@ -32,7 +29,7 @@ build() {
make -j4 libcef_dll_wrapper
}
package() {
- mkdir -p "$pkgdir"/opt/cef-minimal/
- cp -R "$srcdir"/cef_binary_${pkgver}.${_subver}_linux${_arch}_minimal/* "$pkgdir"/opt/cef-minimal
+ mkdir -p "$pkgdir"/opt/cef/
+ cp -R "$srcdir"/cef_binary_${pkgver}.${_subver}_linux${_arch}_minimal/* "$pkgdir"/opt/cef
install -Dm644 "$srcdir"/cef_binary_${pkgver}.${_subver}_linux${_arch}_minimal/LICENSE.txt "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}