summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-03-08 15:22:48 -0500
committerPatrick Northon2023-03-08 15:22:48 -0500
commit53ab93b3ac8ce28dbdaa376aa1b17251a3fa3fdf (patch)
tree0cd5caab67ce25ff199e3fad2ec10c4974e684c8
parent42760c7eb69265299834ca0b438708242c47bc96 (diff)
downloadaur-53ab93b3ac8ce28dbdaa376aa1b17251a3fa3fdf.tar.gz
Update version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2ec12e68f9e..d12a19eaaddc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-plugin-input-overlay
pkgdesc = obs-studio plugin to show keyboard, gamepad and mouse input on stream.
- pkgver = 5.0.0
- pkgrel = 2
+ pkgver = 5.0.2
+ pkgrel = 1
url = https://github.com/univrsal/input-overlay
arch = x86_64
groups = obs-plugins
@@ -11,13 +11,11 @@ pkgbase = obs-plugin-input-overlay
depends = obs-studio
depends = libxtst
depends = libxkbfile
- source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.0
- source = obs-plugin-input-overlay-netlib::git+https://github.com/univrsal/netlib.git
+ source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.2
source = obs-plugin-input-overlay-libgamepad::git+https://github.com/univrsal/libgamepad.git
source = obs-plugin-input-overlay-libuiohook::git+https://github.com/kwhat/libuiohook.git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
pkgname = obs-plugin-input-overlay
diff --git a/PKGBUILD b/PKGBUILD
index 6da02f2a2dde..d1a336b36281 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname='input-overlay'
pkgname=obs-plugin-${_pkgname}
-pkgver=5.0.0
-pkgrel=2
+pkgver=5.0.2
+pkgrel=1
groups=('obs-plugins')
pkgdesc='obs-studio plugin to show keyboard, gamepad and mouse input on stream.'
arch=("x86_64")
@@ -15,12 +15,10 @@ depends=('obs-studio' 'libxtst' 'libxkbfile')
makedepends=('git' 'cmake')
source=(
"git+https://github.com/univrsal/${_pkgname}.git#tag=v${pkgver}"
- "$pkgname-netlib::git+https://github.com/univrsal/netlib.git"
"$pkgname-libgamepad::git+https://github.com/univrsal/libgamepad.git"
"$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git")
md5sums=('SKIP'
'SKIP'
- 'SKIP'
'SKIP')
_srcdir="${_pkgname}"
@@ -28,14 +26,13 @@ _srcdir="${_pkgname}"
prepare() {
cd "${_srcdir}"
git submodule init
- git config 'submodule.deps/netlib.url' "$srcdir/$pkgname-netlib"
git config 'submodule.deps/libgamepad.url' "$srcdir/$pkgname-libgamepad"
git config 'submodule.deps/libuiohook.url' "$srcdir/$pkgname-libuiohook"
git -c 'protocol.file.allow=always' submodule update
}
build() {
- cmake -S "${_srcdir}" -B 'build' -DCMAKE_BUILD_TYPE='None' -DCMAKE_INSTALL_PREFIX='/usr'
+ CXXFLAGS="$CXXFLAGS -msse4.1" cmake -S "${_srcdir}" -B 'build' -DCMAKE_BUILD_TYPE='None' -DCMAKE_INSTALL_PREFIX='/usr'
cmake --build 'build'
}