summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-12-08 08:03:38 -0500
committerPatrick Northon2023-12-08 08:03:38 -0500
commit779078e42dda10503ab21062ca79c358976e7fbd (patch)
tree000a936351997ff29a955f38533effa13d52f9c5
parentac012e66cdbafb3158ead320b5fcbac02dccc469 (diff)
downloadaur-779078e42dda10503ab21062ca79c358976e7fbd.tar.gz
Update version.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fd4c8cf7f53..66259a158b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-plugin-input-overlay
pkgdesc = obs-studio plugin to show keyboard, gamepad and mouse input on stream.
- pkgver = 5.0.3
- pkgrel = 2
+ pkgver = 5.0.4
+ pkgrel = 1
url = https://github.com/univrsal/input-overlay
arch = x86_64
groups = obs-plugins
@@ -11,13 +11,7 @@ pkgbase = obs-plugin-input-overlay
depends = obs-studio
depends = libxtst
depends = libxkbfile
- source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.3
- source = obs-plugin-input-overlay-libgamepad::git+https://github.com/univrsal/libgamepad.git
- source = obs-plugin-input-overlay-libuiohook::git+https://github.com/kwhat/libuiohook.git
- source = https://github.com/univrsal/input-overlay/commit/886d0740a366d826e638a988b9b26a9070d1176e.patch
+ source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.4
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = e4127eef7a832ab898041ca0b44e8ca363f6026f080d65902af2dd9c82328e29
pkgname = obs-plugin-input-overlay
diff --git a/PKGBUILD b/PKGBUILD
index 9179e26ee8e3..c00f9a73dc33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname='input-overlay'
pkgname=obs-plugin-${_pkgname}
-pkgver=5.0.3
-pkgrel=2
+pkgver=5.0.4
+pkgrel=1
groups=('obs-plugins')
pkgdesc='obs-studio plugin to show keyboard, gamepad and mouse input on stream.'
arch=("x86_64")
@@ -15,25 +15,20 @@ depends=('obs-studio' 'libxtst' 'libxkbfile')
makedepends=('git' 'cmake')
source=(
"git+https://github.com/univrsal/${_pkgname}.git#tag=v${pkgver}"
- "$pkgname-libgamepad::git+https://github.com/univrsal/libgamepad.git"
- "$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git"
- "https://github.com/univrsal/${_pkgname}/commit/886d0740a366d826e638a988b9b26a9070d1176e.patch")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'e4127eef7a832ab898041ca0b44e8ca363f6026f080d65902af2dd9c82328e29')
+ # Does not work as it is using a commit not part of any branches.
+ #"$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git"
+ )
+sha256sums=('SKIP')
_srcdir="${_pkgname}"
prepare() {
cd "${_srcdir}"
git submodule init
- git config 'submodule.deps/libgamepad.url' "$srcdir/$pkgname-libgamepad"
- git config 'submodule.deps/libuiohook.url' "$srcdir/$pkgname-libuiohook"
+ #git config 'submodule.deps/libuiohook.url' "$srcdir/$pkgname-libuiohook"
git -c 'protocol.file.allow=always' submodule update
sed -i '/set(CMAKE_CXX_FLAGS "-march=native")/d' 'CMakeLists.txt'
- patch -p1 -i '../886d0740a366d826e638a988b9b26a9070d1176e.patch'
}
build() {