summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-05-07 22:56:28 -0400
committerPatrick Northon2023-05-07 22:56:28 -0400
commitac012e66cdbafb3158ead320b5fcbac02dccc469 (patch)
treea912a57267388024529b96a96cb69cd8d46edd86
parentf7fba68d77a40f3662d413603b71917d2f63f560 (diff)
downloadaur-ac012e66cdbafb3158ead320b5fcbac02dccc469.tar.gz
Cherry-pick a patch to fix compile.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5660cc5e8d6..0fd4c8cf7f53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-plugin-input-overlay
pkgdesc = obs-studio plugin to show keyboard, gamepad and mouse input on stream.
pkgver = 5.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/univrsal/input-overlay
arch = x86_64
groups = obs-plugins
@@ -14,8 +14,10 @@ pkgbase = obs-plugin-input-overlay
source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.3
source = obs-plugin-input-overlay-libgamepad::git+https://github.com/univrsal/libgamepad.git
source = obs-plugin-input-overlay-libuiohook::git+https://github.com/kwhat/libuiohook.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = https://github.com/univrsal/input-overlay/commit/886d0740a366d826e638a988b9b26a9070d1176e.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = e4127eef7a832ab898041ca0b44e8ca363f6026f080d65902af2dd9c82328e29
pkgname = obs-plugin-input-overlay
diff --git a/PKGBUILD b/PKGBUILD
index 25fc90eff2c3..9179e26ee8e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname='input-overlay'
pkgname=obs-plugin-${_pkgname}
pkgver=5.0.3
-pkgrel=1
+pkgrel=2
groups=('obs-plugins')
pkgdesc='obs-studio plugin to show keyboard, gamepad and mouse input on stream.'
arch=("x86_64")
@@ -16,10 +16,12 @@ makedepends=('git' 'cmake')
source=(
"git+https://github.com/univrsal/${_pkgname}.git#tag=v${pkgver}"
"$pkgname-libgamepad::git+https://github.com/univrsal/libgamepad.git"
- "$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git")
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP')
+ "$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git"
+ "https://github.com/univrsal/${_pkgname}/commit/886d0740a366d826e638a988b9b26a9070d1176e.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e4127eef7a832ab898041ca0b44e8ca363f6026f080d65902af2dd9c82328e29')
_srcdir="${_pkgname}"
@@ -31,6 +33,7 @@ prepare() {
git -c 'protocol.file.allow=always' submodule update
sed -i '/set(CMAKE_CXX_FLAGS "-march=native")/d' 'CMakeLists.txt'
+ patch -p1 -i '../886d0740a366d826e638a988b9b26a9070d1176e.patch'
}
build() {