summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-12-08 22:17:09 -0500
committerPatrick Northon2023-12-08 22:17:09 -0500
commitb7d72e3e7326fcfa3a2810b5ba9aa55a05157ff2 (patch)
treeca5d6e13c833141dc0b66db3c688f31c1df5cd44
parent779078e42dda10503ab21062ca79c358976e7fbd (diff)
downloadaur-b7d72e3e7326fcfa3a2810b5ba9aa55a05157ff2.tar.gz
Fix submodule.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66259a158b45..7fe91a76da9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-plugin-input-overlay
pkgdesc = obs-studio plugin to show keyboard, gamepad and mouse input on stream.
pkgver = 5.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/univrsal/input-overlay
arch = x86_64
groups = obs-plugins
@@ -12,6 +12,10 @@ pkgbase = obs-plugin-input-overlay
depends = libxtst
depends = libxkbfile
source = git+https://github.com/univrsal/input-overlay.git#tag=v5.0.4
+ source = obs-plugin-input-overlay-libuiohook-univrsal::git+https://github.com/univrsal/libuiohook.git
+ source = obs-plugin-input-overlay-libuiohook-submodule.patch::https://github.com/univrsal/input-overlay/commit/b7db35b53b1332e1e08d332d7c81e6296289df44.patch
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 0ace525bb60a3c9e52cd6f9bb091cc456338e80a8b80d2e77dce9638574cc5c3
pkgname = obs-plugin-input-overlay
diff --git a/PKGBUILD b/PKGBUILD
index c00f9a73dc33..8ba7889f72f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname='input-overlay'
pkgname=obs-plugin-${_pkgname}
pkgver=5.0.4
-pkgrel=1
+pkgrel=2
groups=('obs-plugins')
pkgdesc='obs-studio plugin to show keyboard, gamepad and mouse input on stream.'
arch=("x86_64")
@@ -15,17 +15,20 @@ depends=('obs-studio' 'libxtst' 'libxkbfile')
makedepends=('git' 'cmake')
source=(
"git+https://github.com/univrsal/${_pkgname}.git#tag=v${pkgver}"
- # Does not work as it is using a commit not part of any branches.
- #"$pkgname-libuiohook::git+https://github.com/kwhat/libuiohook.git"
- )
-sha256sums=('SKIP')
+ "$pkgname-libuiohook-univrsal::git+https://github.com/univrsal/libuiohook.git"
+ "$pkgname-libuiohook-submodule.patch::https://github.com/univrsal/input-overlay/commit/b7db35b53b1332e1e08d332d7c81e6296289df44.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ '0ace525bb60a3c9e52cd6f9bb091cc456338e80a8b80d2e77dce9638574cc5c3')
_srcdir="${_pkgname}"
prepare() {
cd "${_srcdir}"
+ patch -p1 -i "$srcdir/$pkgname-libuiohook-submodule.patch"
+
git submodule init
- #git config 'submodule.deps/libuiohook.url' "$srcdir/$pkgname-libuiohook"
+ git config 'submodule.deps/libuiohook.url' "$srcdir/$pkgname-libuiohook-univrsal"
git -c 'protocol.file.allow=always' submodule update
sed -i '/set(CMAKE_CXX_FLAGS "-march=native")/d' 'CMakeLists.txt'