summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrx862023-06-08 11:05:46 +0800
committerBrx862023-06-08 11:05:46 +0800
commit86cb9014c18f39c0119da46962137b318a1f04f7 (patch)
tree4a09433d65536578d9a2e9b01113260af85ba6d4
downloadaur-86cb9014c18f39c0119da46962137b318a1f04f7.tar.gz
first upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd43a71f84ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = obs-plugin-waveform-bin
+ pkgdesc = Waveform is an audio spectral analysis plugin for OBS Studio
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://github.com/phandasm/waveform
+ arch = x86_64
+ license = GPL3
+ makedepends = tar
+ depends = obs-studio>=28.0.0
+ conflicts = obs-plugin-waveform-git
+ options = !strip
+ options = emptydirs
+ source = https://github.com/phandasm/waveform/releases/download/v1.6.1/Waveform_v1.6.1_Ubuntu_x86_64.deb
+ sha256sums = 8ac0bdc4e9f4d5b9de1318f73c440413485a0f4e7422d4dbf9a0bb61193951d1
+
+pkgname = obs-plugin-waveform-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ada8c67b8b67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ayatale <ayatale8@gmail.com>
+
+pkgname=obs-plugin-waveform-bin
+_pkgname=${pkgname%-bin}
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Waveform is an audio spectral analysis plugin for OBS Studio"
+arch=("x86_64")
+url="https://github.com/phandasm/waveform"
+license=("GPL3")
+depends=("obs-studio>=28.0.0")
+makedepends=("tar")
+conflicts=("${_pkgname}-git")
+options=("!strip" "emptydirs")
+source=("${url}/releases/download/v${pkgver}/Waveform_v${pkgver}_Ubuntu_x86_64.deb")
+sha256sums=("8ac0bdc4e9f4d5b9de1318f73c440413485a0f4e7422d4dbf9a0bb61193951d1")
+
+_install() {
+ find ${@: 2} -type f -exec install -Dm$1 {} ${pkgdir}/{} \;
+}
+
+build() {
+ rm -rf ${srcdir}/build
+ mkdir -p ${srcdir}/build
+ tar -xf ${srcdir}/data.tar.gz -C ${srcdir}/build
+}
+
+package() {
+ cd ${srcdir}/build/
+ install -Dm755 usr/lib/x86_64-linux-gnu/obs-plugins/waveform.so -t ${pkgdir}/usr/lib/obs-plugins/
+ find usr/share/obs/obs-plugins/waveform -type f -exec install -Dm755 {} ${pkgdir}/{} \;
+} \ No newline at end of file