summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo "ThePooN" Denizart2016-08-26 16:58:30 +0200
committerHugo "ThePooN" Denizart2016-08-26 16:58:30 +0200
commitbdb08594adb9c804cd343d29ebf4e0a85d776989 (patch)
treee1849aa039b67e5cff5d991884775378fd858cb6
parentc8c3e7745d1e72d0092b730af93a4cf7db580295 (diff)
downloadaur-bdb08594adb9c804cd343d29ebf4e0a85d776989.tar.gz
edit patch in order to set right install paths
-rw-r--r--000_install_path.patch35
-rw-r--r--PKGBUILD2
2 files changed, 31 insertions, 6 deletions
diff --git a/000_install_path.patch b/000_install_path.patch
index 78f047cc5543..956c7b376c12 100644
--- a/000_install_path.patch
+++ b/000_install_path.patch
@@ -1,14 +1,39 @@
--- a/Makefile
+++ b/Makefile
-@@ -20,7 +20,10 @@ RENDERER_SRC = src/qtwebkit-renderer.cpp
+@@ -20,18 +20,17 @@ RENDERER_SRC = src/qtwebkit-renderer.cpp
RENDERER_OBJ = build/qtwebkit-renderer.o
PLUGIN_BUILD_DIR = build/qtwebkit-browser
-PLUGIN_INSTALL_DIR = ~/.config/obs-studio/plugins
-+PLUGIN_INSTALL_DIR = /usr/share/obs/obs-plugins
+-ifdef OBS_PLUGIN_INSTALL_OLD
+-PLUGIN_INSTALL_DIR = ~/.obs-studio/plugins
+-endif
+ PLUGIN_DATA_DIR = data
+
+-ARCH = $(shell getconf LONG_BIT)
+-PLUGIN_BIN_DIR = $(PLUGIN_BUILD_DIR)/bin/$(ARCH)bit
+-ifdef OBS_PLUGIN_BUILD_OLD
+-PLUGIN_BIN_DIR = $(PLUGIN_BUILD_DIR)/bin
++PLUGIN_INSTALL_DIR = /usr/lib/obs-plugins
++PLUGIN_INSTALL_DATA_DIR = /usr/share/obs/obs-plugins/qtwebkit-browser
+ifdef PREFIX
+PLUGIN_INSTALL_DIR := $(PREFIX)$(PLUGIN_INSTALL_DIR)
-+endif
- ifdef OBS_PLUGIN_INSTALL_OLD
- PLUGIN_INSTALL_DIR = ~/.obs-studio/plugins
++PLUGIN_INSTALL_DATA_DIR := $(PREFIX)$(PLUGIN_INSTALL_DATA_DIR)
endif
+
++PLUGIN_BIN_DIR = $(PLUGIN_BUILD_DIR)/bin
++
+ all: plugin
+
+ .PHONY: plugin
+@@ -43,7 +42,9 @@ plugin: $(LIB) $(RENDERER)
+ .PHONY: install
+ install:
+ mkdir -p $(PLUGIN_INSTALL_DIR)
+- cp -r $(PLUGIN_BUILD_DIR) $(PLUGIN_INSTALL_DIR)
++ mkdir -p $(PLUGIN_INSTALL_DATA_DIR)
++ cp -r $(PLUGIN_BIN_DIR)/* $(PLUGIN_INSTALL_DIR)
++ cp -r $(PLUGIN_DATA_DIR)/* $(PLUGIN_INSTALL_DATA_DIR)
+
+ $(RENDERER): $(RENDERER_OBJ)
+ $(CXX) $(LDFLAGS) $^ $(LDLIBS_RENDERER) -o $@
diff --git a/PKGBUILD b/PKGBUILD
index c63a9eba8753..0d1795b30b06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ provides=("obs-qtwebkit")
source=("$pkgname::git+https://github.com/bazukas/obs-qtwebkit#branch=master"
"000_install_path.patch")
md5sums=("SKIP"
- "c43621528052ad14fadb2fc814c030cd")
+ "8dbde6438cb2fea91478b472abf66edb")
pkgver() {
cd $pkgname