summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo "ThePooN" Denizart2016-08-26 16:16:45 +0200
committerHugo "ThePooN" Denizart2016-08-26 16:17:31 +0200
commitc8c3e7745d1e72d0092b730af93a4cf7db580295 (patch)
treecde007b5b106df2107823a1d14c2aa12938e9e44
downloadaur-c8c3e7745d1e72d0092b730af93a4cf7db580295.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--000_install_path.patch14
-rw-r--r--PKGBUILD38
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5fe98121a25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = obs-qtwebkit-git
+ pkgdesc = Browser source plugin for obs-studio based on QtWebkit library.
+ pkgver = 3dd7cde
+ pkgrel = 1
+ url = https://github.com/bazukas/obs-qtwebkit
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = obs-studio
+ makedepends = qt5-base
+ makedepends = qt5-webkit
+ depends = obs-studio
+ depends = qt5-base
+ depends = qt5-webkit
+ provides = obs-qtwebkit
+ source = obs-qtwebkit-git::git+https://github.com/bazukas/obs-qtwebkit#branch=master
+ source = 000_install_path.patch
+ md5sums = SKIP
+ md5sums = c43621528052ad14fadb2fc814c030cd
+
+pkgname = obs-qtwebkit-git
+
diff --git a/000_install_path.patch b/000_install_path.patch
new file mode 100644
index 000000000000..78f047cc5543
--- /dev/null
+++ b/000_install_path.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -20,7 +20,10 @@ RENDERER_SRC = src/qtwebkit-renderer.cpp
+ RENDERER_OBJ = build/qtwebkit-renderer.o
+
+ PLUGIN_BUILD_DIR = build/qtwebkit-browser
+-PLUGIN_INSTALL_DIR = ~/.config/obs-studio/plugins
++PLUGIN_INSTALL_DIR = /usr/share/obs/obs-plugins
++ifdef PREFIX
++PLUGIN_INSTALL_DIR := $(PREFIX)$(PLUGIN_INSTALL_DIR)
++endif
+ ifdef OBS_PLUGIN_INSTALL_OLD
+ PLUGIN_INSTALL_DIR = ~/.obs-studio/plugins
+ endif
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c63a9eba8753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Hugo Denizart <thepoon@cartooncraft.fr>
+
+pkgname=obs-qtwebkit-git
+pkgver=3dd7cde
+pkgrel=1
+pkgdesc="Browser source plugin for obs-studio based on QtWebkit library."
+arch=("i686" "x86_64")
+url="https://github.com/bazukas/obs-qtwebkit"
+license=("GPL2")
+depends=("obs-studio" "qt5-base" "qt5-webkit")
+makedepends=("make" "git")
+provides=("obs-qtwebkit")
+source=("$pkgname::git+https://github.com/bazukas/obs-qtwebkit#branch=master"
+ "000_install_path.patch")
+md5sums=("SKIP"
+ "c43621528052ad14fadb2fc814c030cd")
+
+pkgver() {
+ cd $pkgname
+ git rev-parse --short HEAD
+}
+
+prepare() {
+ cd $pkgname
+ patch -u < ../000_install_path.patch
+}
+
+build() {
+ cd $pkgname
+
+ make
+}
+
+package() {
+ cd $pkgname
+
+ PREFIX=$pkgdir make install
+}