summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-11-01 08:45:51 +0100
committertytan6522023-11-01 08:45:51 +0100
commit0e9094d7b82dc0a9a8f7a5d5ef50d867353dfbec (patch)
tree5b17265b0c00fb6cd9f64ce28f4fa59527e848b4
parente43bcc457314fb068696c9a47fb11b65bc9ca8b8 (diff)
downloadaur-0e9094d7b82dc0a9a8f7a5d5ef50d867353dfbec.tar.gz
build: Update to version 0.0.6 and add debug
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcc755a47241..762598bc9163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-recursion-effect
pkgdesc = Plugin for add recursion effect to a source using a filter
- pkgver = 0.0.5
+ pkgver = 0.0.6
pkgrel = 1
url = https://obsproject.com/forum/resources/recursion-effect.1008/
arch = x86_64
@@ -9,7 +9,8 @@ pkgbase = obs-recursion-effect
makedepends = cmake
makedepends = git
depends = obs-studio>=28
- source = obs-recursion-effect::git+https://github.com/exeldro/obs-recursion-effect#commit=c201ab49997ab96288e5a40fd9239de5066441a0
+ options = debug
+ source = obs-recursion-effect::git+https://github.com/exeldro/obs-recursion-effect#commit=bf726d0a3e9429c8c447fc1d87b3a932b2a6ad90
sha256sums = SKIP
pkgname = obs-recursion-effect
diff --git a/PKGBUILD b/PKGBUILD
index 692526b1a3f2..92e343879fc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-recursion-effect
-pkgver=0.0.5
+pkgver=0.0.6
pkgrel=1
pkgdesc="Plugin for add recursion effect to a source using a filter"
arch=("x86_64" "aarch64")
@@ -9,13 +9,14 @@ url="https://obsproject.com/forum/resources/recursion-effect.1008/"
license=("GPL2")
depends=("obs-studio>=28")
makedepends=("cmake" "git")
-source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=c201ab49997ab96288e5a40fd9239de5066441a0")
+options=('debug')
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=bf726d0a3e9429c8c447fc1d87b3a932b2a6ad90")
sha256sums=("SKIP")
build() {
cd "$pkgname"
cmake -B build \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \