summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-01-10 14:28:47 +0100
committertytan6522024-01-10 14:28:47 +0100
commit26b4ca29373940773447cb7fe081ac66f8e562bc (patch)
tree05a926b9db4a8d824cd90f932df0d75e81035e21
parent0e9094d7b82dc0a9a8f7a5d5ef50d867353dfbec (diff)
downloadaur-26b4ca29373940773447cb7fe081ac66f8e562bc.tar.gz
build: Update to version 0.1.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 762598bc9163..b30f221efa2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-recursion-effect
pkgdesc = Plugin for add recursion effect to a source using a filter
- pkgver = 0.0.6
+ pkgver = 0.1.0
pkgrel = 1
url = https://obsproject.com/forum/resources/recursion-effect.1008/
arch = x86_64
@@ -9,8 +9,9 @@ pkgbase = obs-recursion-effect
makedepends = cmake
makedepends = git
depends = obs-studio>=28
+ depends = glibc
options = debug
- source = obs-recursion-effect::git+https://github.com/exeldro/obs-recursion-effect#commit=bf726d0a3e9429c8c447fc1d87b3a932b2a6ad90
+ source = obs-recursion-effect::git+https://github.com/exeldro/obs-recursion-effect#commit=61a835ecda4209e8678197b1e9582ede582aa876
sha256sums = SKIP
pkgname = obs-recursion-effect
diff --git a/PKGBUILD b/PKGBUILD
index 92e343879fc0..1a2b4b50835a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
pkgname=obs-recursion-effect
-pkgver=0.0.6
+pkgver=0.1.0
pkgrel=1
pkgdesc="Plugin for add recursion effect to a source using a filter"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/recursion-effect.1008/"
license=("GPL2")
-depends=("obs-studio>=28")
+depends=("obs-studio>=28" "glibc")
makedepends=("cmake" "git")
options=('debug')
-source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=bf726d0a3e9429c8c447fc1d87b3a932b2a6ad90")
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=61a835ecda4209e8678197b1e9582ede582aa876")
sha256sums=("SKIP")
build() {
- cd "$pkgname"
- cmake -B build \
+ cmake -B build -S $pkgname \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6
+ -Wno-dev
- make -C build
+ cmake --build build
}
package() {
- cd "$pkgname"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
}