summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-10-26 13:28:15 +0200
committertytan6522021-10-26 13:28:15 +0200
commitd334857f57f7578ae078d414e58bf5a340198b0f (patch)
tree317db562ccb36a7353d80e172e7eec3353094cee
parentcf4bb9e05dfdfeec7350141e24bf28c61eac8516 (diff)
downloadaur-d334857f57f7578ae078d414e58bf5a340198b0f.tar.gz
build: Nitpicking
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c149551aa28b..401830fce7df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = obs-recursion-effect
makedepends = git
makedepends = libxcomposite
depends = obs-studio>=27.0.0
- source = obs-recursion-effect-0.0.3::git+https://github.com/exeldro/obs-recursion-effect#commit=a4b92d836224a80eb7d61cc7f6b839290faf1864
+ source = obs-recursion-effect::git+https://github.com/exeldro/obs-recursion-effect#commit=a4b92d836224a80eb7d61cc7f6b839290faf1864
source = obs-studio-27.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.0.0.tar.gz
sha256sums = SKIP
sha256sums = c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e
diff --git a/PKGBUILD b/PKGBUILD
index 5c4aeedeedba..a9ff9d109f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
_pluginname=recursion-effect
pkgname=obs-$_pluginname
pkgver=0.0.3
@@ -11,7 +12,7 @@ license=("GPL2")
depends=("obs-studio>=$_obsver")
makedepends=("cmake" "git" "libxcomposite")
source=(
- "$pkgname-$pkgver::git+https://github.com/exeldro/obs-recursion-effect#commit=a4b92d836224a80eb7d61cc7f6b839290faf1864"
+ "$pkgname::git+https://github.com/exeldro/$pkgname#commit=a4b92d836224a80eb7d61cc7f6b839290faf1864"
"obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
)
sha256sums=(
@@ -23,8 +24,8 @@ prepare() {
rm -rf fakeroot
cd "obs-studio-$_obsver"/plugins
- cp -r "$srcdir/$pkgname-$pkgver" .
- echo "add_subdirectory($pkgname-$pkgver)" | tee -a CMakeLists.txt >/dev/null
+ cp -r "$srcdir/$pkgname" .
+ echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
}
# Need to compile plugin in OBS compilation process