summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522024-03-17 18:14:25 +0100
committertytan6522024-03-17 18:14:25 +0100
commit33e6123eaae102a8ef6705453e67ce56eb4a641a (patch)
tree012933f42d8d05833ae97c3408f2cb0160a038c7
parent345bba1f4efc9c43972970795ded421b5727eca9 (diff)
downloadaur-33e6123eaae102a8ef6705453e67ce56eb4a641a.tar.gz
build: Allow deprecation for future-proofing
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f5f61ac1f0e..2be34b11acee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="Plugin for OBS Studio to add a Scene Collection Manager"
arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/scene-collection-manager.1434/"
-license=("GPL2")
+license=("GPL-2.0-or-later")
depends=("obs-studio>=28" "gcc-libs" "glibc" "qt6-base")
makedepends=("cmake" "git")
options=('debug')
@@ -19,7 +19,9 @@ build() {
-DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
-DLINUX_PORTABLE=OFF \
- -DQT_VERSION=6
+ -DQT_VERSION=6 \
+ -DCMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations" \
+ -Wno-dev
cmake --build build
}