diff options
author | tytan652 | 2024-03-17 18:14:25 +0100 |
---|---|---|
committer | tytan652 | 2024-03-17 18:14:25 +0100 |
commit | 33e6123eaae102a8ef6705453e67ce56eb4a641a (patch) | |
tree | 012933f42d8d05833ae97c3408f2cb0160a038c7 | |
parent | 345bba1f4efc9c43972970795ded421b5727eca9 (diff) | |
download | aur-33e6123eaae102a8ef6705453e67ce56eb4a641a.tar.gz |
build: Allow deprecation for future-proofing
-rw-r--r-- | PKGBUILD | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -6,7 +6,7 @@ pkgrel=1 pkgdesc="Plugin for OBS Studio to add a Scene Collection Manager" arch=("x86_64" "aarch64") url="https://obsproject.com/forum/resources/scene-collection-manager.1434/" -license=("GPL2") +license=("GPL-2.0-or-later") depends=("obs-studio>=28" "gcc-libs" "glibc" "qt6-base") makedepends=("cmake" "git") options=('debug') @@ -19,7 +19,9 @@ build() { -DCMAKE_INSTALL_PREFIX='/usr' \ -DCMAKE_INSTALL_LIBDIR=lib \ -DLINUX_PORTABLE=OFF \ - -DQT_VERSION=6 + -DQT_VERSION=6 \ + -DCMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations" \ + -Wno-dev cmake --build build } |