summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-17 22:56:06 +0100
committertytan6522022-02-17 22:56:06 +0100
commit3e741ebf173b23f219305c2b106cf4a6b9138281 (patch)
tree9e189cea72549fbe94723df2c4410fe9f8e3793d
parentc71467ecd07f93bf0397081ac23da5aac54e1e78 (diff)
downloadaur-3e741ebf173b23f219305c2b106cf4a6b9138281.tar.gz
build: Fix build issue with ffmpeg4.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31b92be44cc6..ff06f957f22f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-scrab
- pkgdesc = adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene
+ pkgdesc = Adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene
pkgver = 1.1
- pkgrel = 2
+ pkgrel = 3
url = https://obsproject.com/forum/resources/scrab.845/
arch = i686
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = obs-scrab
makedepends = cmake
makedepends = git
makedepends = libxcomposite
- depends = obs-studio>=27.0.0
+ makedepends = ffmpeg
+ depends = obs-studio>=27.2.0
source = obs-scrab-1.1.tar.gz::https://github.com/univrsal/scrab/archive/v1.1.tar.gz
- source = obs-studio-27.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.0.0.tar.gz
+ source = obs-studio-27.2.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.2.0.tar.gz
sha256sums = d0e14a0fc62591820b2188eecb472afa7e89e9419461b29e605ebf25dce6204e
- sha256sums = c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e
+ sha256sums = c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789
pkgname = obs-scrab
diff --git a/PKGBUILD b/PKGBUILD
index ad4963c2cf9f..deee0d304351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
_pluginname=scrab
pkgname=obs-$_pluginname
pkgver=1.1
-_obsver=27.0.0
-pkgrel=2
-pkgdesc="adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene"
+_obsver=27.2.0
+pkgrel=3
+pkgdesc="Adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/scrab.845/"
license=("GPL2")
depends=("obs-studio>=$_obsver")
-makedepends=("cmake" "git" "libxcomposite")
+makedepends=("cmake" "git" "libxcomposite" "ffmpeg")
source=(
"$pkgname-$pkgver.tar.gz"::"https://github.com/univrsal/$_pluginname/archive/v$pkgver.tar.gz"
"obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
)
sha256sums=(
"d0e14a0fc62591820b2188eecb472afa7e89e9419461b29e605ebf25dce6204e"
- "c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e"
+ "c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789"
)
prepare() {