summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-02-02 13:38:40 +0100
committertytan6522021-02-02 13:38:40 +0100
commit54e1b6a53e68c5aa463e67f902239e243353b186 (patch)
tree5d57b3bba0551c204f240cdcf62e2c6a3002ad94
downloadaur-54e1b6a53e68c5aa463e67f902239e243353b186.tar.gz
build: add version 1.1
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD55
-rw-r--r--fix_python_binary_loading.patch24
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7722451fa13c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = obs-scrab
+ pkgdesc = adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/univrsal/dvds3
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = libfdk-aac
+ makedepends = libxcomposite
+ makedepends = x264
+ makedepends = vlc
+ makedepends = swig
+ makedepends = python
+ makedepends = luajit
+ makedepends = ffmpeg
+ makedepends = jansson
+ makedepends = libxinerama
+ makedepends = libxkbcommon-x11
+ makedepends = mbedtls
+ makedepends = qt5-svg
+ makedepends = qt5-x11extras
+ makedepends = curl
+ makedepends = jack
+ makedepends = gtk-update-icon-cache
+ depends = obs-studio
+ source = obs-scrab-1.1.tar.gz::https://github.com/univrsal/scrab/archive/v1.1.tar.gz
+ source = obs-studio-26.1.2.tar.gz::https://github.com/obsproject/obs-studio/archive/26.1.2.tar.gz
+ source = fix_python_binary_loading.patch
+ sha256sums = d0e14a0fc62591820b2188eecb472afa7e89e9419461b29e605ebf25dce6204e
+ sha256sums = bc8b4c61ba4aae87b70c589a6a5b8538e4f03121b31e9b98a2071d9f6006b897
+ sha256sums = bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd
+
+pkgname = obs-scrab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce4f94569ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+_pluginname=scrab
+pkgname=obs-scrab
+pkgver=1.1
+_obsver=26.1.2
+pkgrel=1
+pkgdesc="adds a configurable hotkey to quickly select a screen region and add it as an image source to the current scene"
+arch=('x86_64')
+url="https://github.com/univrsal/dvds3"
+license=("GPL2")
+depends=("obs-studio")
+# Need to compile plugin in OBS compilation process
+makedepends=(
+ 'cmake' 'libfdk-aac' 'libxcomposite' 'x264' 'vlc' 'swig' 'python'
+ 'luajit' 'ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls'
+ 'qt5-svg' 'qt5-x11extras' 'curl' 'jack' 'gtk-update-icon-cache'
+)
+source=(
+ "$pkgname-$pkgver.tar.gz"::"https://github.com/univrsal/$_pluginname/archive/v$pkgver.tar.gz"
+ "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
+ "fix_python_binary_loading.patch"
+)
+sha256sums=(
+ 'd0e14a0fc62591820b2188eecb472afa7e89e9419461b29e605ebf25dce6204e'
+ 'bc8b4c61ba4aae87b70c589a6a5b8538e4f03121b31e9b98a2071d9f6006b897'
+ 'bdfbd062f080bc925588aec1989bb1df34bf779cc2fc08ac27236679cf612abd'
+)
+
+prepare() {
+ rm -rf fakeroot
+ cd "obs-studio-$_obsver"
+ patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
+ cd plugins
+ cp -r "$srcdir/$_pluginname-$pkgver" .
+ echo "add_subdirectory($_pluginname-$pkgver)" | tee -a CMakeLists.txt >/dev/null
+}
+
+# Need to compile plugin in OBS compilation process
+build() {
+ cd "obs-studio-$_obsver"
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DBUILD_CAPTIONS=ON
+ make -C build
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/obs-plugins
+ mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
+
+ cd "obs-studio-$_obsver"
+ make -C build DESTDIR="$srcdir/fakeroot/" install
+ cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/scrab.so "$pkgdir"/usr/lib/obs-plugins/
+ cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/scrab "$pkgdir"/usr/share/obs/obs-plugins/
+} \ No newline at end of file
diff --git a/fix_python_binary_loading.patch b/fix_python_binary_loading.patch
new file mode 100644
index 000000000000..6cba55f2f1af
--- /dev/null
+++ b/fix_python_binary_loading.patch
@@ -0,0 +1,24 @@
+From c482159ce93deafc7f1fc5755ba15135709ae726 Mon Sep 17 00:00:00 2001
+From: Matt Gajownik <matt@obsproject.com>
+Date: Tue, 25 Aug 2020 19:28:26 +1000
+Subject: [PATCH] libobs/util: Fix loading Python binary modules on *nix
+
+Fixes #2222
+---
+ libobs/util/platform-nix.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libobs/util/platform-nix.c b/libobs/util/platform-nix.c
+index 26800d52f7..997b62db1a 100644
+--- a/libobs/util/platform-nix.c
++++ b/libobs/util/platform-nix.c
+@@ -71,7 +71,8 @@ void *os_dlopen(const char *path)
+ #ifdef __APPLE__
+ void *res = dlopen(dylib_name.array, RTLD_LAZY | RTLD_FIRST);
+ #else
+- void *res = dlopen(dylib_name.array, RTLD_LAZY);
++ void *res = dlopen(dylib_name.array,
++ RTLD_LAZY | RTLD_DEEPBIND | RTLD_GLOBAL);
+ #endif
+ if (!res)
+ blog(LOG_ERROR, "os_dlopen(%s->%s): %s\n", path,