summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-31 16:55:23 +0800
committermaz-12015-10-31 16:55:23 +0800
commitba8593fe70e6d42e716a422445dfedeaac9dee87 (patch)
tree88b99262c1c118968d7a982d55c0349d23a00c6f
downloadaur-ba8593fe70e6d42e716a422445dfedeaac9dee87.tar.gz
move to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..929e9b385773
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = obs-service-download_files
+ pkgdesc = An OBS source service: downloads all remote sources listed in a spec file
+ pkgver = 0.5
+ pkgrel = 2
+ url = https://github.com/openSUSE/obs-service-download_files
+ arch = any
+ license = GPL2
+ depends = obs-build-git
+ depends = diffutils
+ depends = wget
+ depends = perl-uri
+ source = http://download.opensuse.org/source/distribution/13.1/repo/oss/suse/src/obs-service-download_files-0.5-3.1.2.src.rpm
+ sha256sums = ce2f8ba0746a0cea6a7db3633f3584f14753ff739ea33c38c357112de10f9dd6
+
+pkgname = obs-service-download_files
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94cc383381ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Patrick McCarty <pnorcks at gmail dot com>
+
+pkgname=obs-service-download_files
+pkgver=0.5
+pkgrel=2
+_pkgrel=3.1.2
+pkgdesc='An OBS source service: downloads all remote sources listed in a spec file'
+arch=('any')
+url='https://github.com/openSUSE/obs-service-download_files'
+license=('GPL2')
+depends=('obs-build-git' 'diffutils' 'wget' 'perl-uri')
+source=("http://download.opensuse.org/source/distribution/13.1/repo/oss/suse/src/${pkgname}-${pkgver}-${_pkgrel}.src.rpm")
+sha256sums=('ce2f8ba0746a0cea6a7db3633f3584f14753ff739ea33c38c357112de10f9dd6')
+
+package() {
+ cd "$srcdir"
+
+ mkdir -p "$pkgdir/usr/lib/obs/service/"
+ install -m755 download_files "$pkgdir/usr/lib/obs/service/"
+ install -m644 download_files.service "$pkgdir/usr/lib/obs/service/"
+ mkdir -p "$pkgdir/etc/obs/services"
+ install -m644 download_files.rc "$pkgdir/etc/obs/services/download_files"
+ mkdir -p $pkgdir/var/cache/obs/download_files/file{,name}
+}
+
+# vim:set ts=2 sw=2 et: