summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2016-01-10 22:16:41 -0600
committerDustin Falgout2016-01-10 22:16:41 -0600
commitf83e550c86c81fb8cdf30a6e09a001e49586a05c (patch)
treebfc943604a32056d91c6d5756910c86957c1f91e
downloadaur-f83e550c86c81fb8cdf30a6e09a001e49586a05c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b85c0baf97aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jan 11 04:16:31 UTC 2016
+pkgbase = obs-service-recompress
+ pkgdesc = Compression Service for the OpenSUSE Build Service (OBS)
+ pkgver = 0.3.1.r14
+ pkgrel = 1
+ url = https://github.com/openSUSE/obs-service-recompress
+ arch = any
+ groups = obs
+ license = GPL3
+ depends = obs-build
+ depends = git
+ source = obs-service-recompress::git+https://github.com/openSUSE/obs-service-recompress.git
+ md5sums = SKIP
+
+pkgname = obs-service-recompress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aabd66ce1a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dustin Falgout <dustin@antergos.com>
+
+pkgname=obs-service-recompress
+_pkgver=0.3.1
+pkgver=${_pkgver}.r14
+pkgrel=1
+pkgdesc="Compression Service for the OpenSUSE Build Service (OBS)"
+arch=('any')
+url="https://github.com/openSUSE/obs-service-recompress"
+license=('GPL3')
+source=("${pkgname}::git+https://github.com/openSUSE/${pkgname}.git")
+groups=('obs')
+depends=('obs-build' 'git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.r%s" "${_pkgver}" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR=${pkgdir} PREFIX=/usr install
+}