summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2016-03-06 01:26:08 -0600
committerDustin Falgout2016-03-06 01:26:08 -0600
commit4fa2172a4f47f8cccb8ef6fc51ed21db4077c3a3 (patch)
treea2e8b1d047a3e6c509e3aa3b72ecbef2444c5203
downloadaur-4fa2172a4f47f8cccb8ef6fc51ed21db4077c3a3.tar.gz
incorporate feedback from Arch TU(s) as it does not seem to matter that I disagree with their opinions regarding these OBS packages (and considering these packages are not in the least bit important to me, its not worth my time to argue).
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0adec2318d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Mar 6 07:13:34 UTC 2016
+pkgbase = obs-service-recompress-git
+ pkgdesc = Compression Service for the OpenSUSE Build Service (OBS)
+ pkgver = 0.3.1.r14
+ pkgrel = 1
+ url = https://github.com/openSUSE/obs-service-recompress
+ arch = any
+ groups = obs
+ license = GPL3
+ depends = obs-build
+ depends = git
+ source = obs-service-recompress-git::git+https://github.com/openSUSE/obs-service-recompress-git.git
+ md5sums = SKIP
+
+pkgname = obs-service-recompress-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c7405225874
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dustin Falgout <dustin@antergos.com>
+
+pkgname=obs-service-recompress-git
+_pkgver=0.3.1
+pkgver="${_pkgver}.r14"
+pkgrel=1
+pkgdesc="Compression Service for the OpenSUSE Build Service (OBS)"
+arch=('any')
+url="https://github.com/openSUSE/obs-service-recompress"
+license=('GPL3')
+source=("${pkgname}::git+https://github.com/openSUSE/${pkgname}.git")
+groups=('obs')
+depends=('obs-build' 'git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.r%s" "${_pkgver}" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}