summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Falgout2016-01-10 22:24:20 -0600
committerDustin Falgout2016-01-10 22:24:20 -0600
commitc3d9ccff7b460f7609ed485f454c2994a89ef267 (patch)
treecedf1c8d06fc4252843d23d84974e6f016b56f30
downloadaur-c3d9ccff7b460f7609ed485f454c2994a89ef267.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..347e543433d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 11 04:24:12 UTC 2016
+pkgbase = obs-service-set_version
+ pkgdesc = Version Service for the OpenSUSE Build Service (OBS)
+ pkgver = 0.5.3.r77
+ pkgrel = 1
+ url = https://github.com/openSUSE/obs-service-set_version
+ arch = any
+ groups = obs
+ license = GPL3
+ depends = obs-build
+ depends = git
+ depends = python2
+ source = obs-service-set_version::git+https://github.com/openSUSE/obs-service-set_version.git
+ md5sums = SKIP
+
+pkgname = obs-service-set_version
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b3475aa6ac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dustin Falgout <dustin@antergos.com>
+
+pkgname=obs-service-set_version
+_pkgver=0.5.3
+pkgver=${_pkgver}.r77
+pkgrel=1
+pkgdesc="Version Service for the OpenSUSE Build Service (OBS)"
+arch=('any')
+url="https://github.com/openSUSE/${pkgname}"
+license=('GPL3')
+source=("${pkgname}::git+https://github.com/openSUSE/${pkgname}.git")
+groups=('obs')
+depends=('obs-build' 'git' 'python2')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.r%s" "${_pkgver}" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR=${pkgdir} PREFIX=/usr install
+}