summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-11-16 08:15:47 +0100
committertytan6522022-11-16 08:15:47 +0100
commitcdbaa1b151357bde26da4b9c0e7352b83a93ec0f (patch)
tree7913e159b61da37a527b39eeb266300cf2fc979d
parente3aafec10572b7920fd5cbc48a15f5859a8913d4 (diff)
downloadaur-cdbaa1b151357bde26da4b9c0e7352b83a93ec0f.tar.gz
build: Update to version 0.3.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD72
2 files changed, 20 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ec7f81e1610..d5844b6315c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
pkgbase = obs-source-record
pkgdesc = Plugin for OBS Studio to add a filter that allows you to record a source
- pkgver = 0.3.0
- pkgrel = 2
+ pkgver = 0.3.1
+ pkgrel = 1
url = https://obsproject.com/forum/resources/source-record.1285/
- arch = i686
arch = x86_64
arch = aarch64
license = GPL2
makedepends = cmake
makedepends = git
- makedepends = libxcomposite
- makedepends = ffmpeg
- makedepends = pciutils
- depends = obs-studio>=28.0.0
- source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=8d71fc5c6994cce68b912ae3c075e39415f982aa
- source = obs-studio-28.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/28.0.0.tar.gz
+ depends = obs-studio>=28
+ source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=4a543d3577d56a27f5f2b9aa541a466b37dafde0
sha256sums = SKIP
- sha256sums = 412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8
pkgname = obs-source-record
diff --git a/PKGBUILD b/PKGBUILD
index c86bd542661d..80c57a89ed7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,70 +1,30 @@
# Maintainer: tytan652 <tytan652@tytanium.xyz>
-_pluginname=source-record
-pkgname=obs-$_pluginname
-pkgver=0.3.0
-_obsver=28.0.0
-pkgrel=2
+pkgname=obs-source-record
+pkgver=0.3.1
+pkgrel=1
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
-arch=("i686" "x86_64" "aarch64")
+arch=("x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
license=("GPL2")
-depends=("obs-studio>=$_obsver")
-makedepends=("cmake" "git" "libxcomposite" "ffmpeg" "pciutils")
-source=(
- "$pkgname::git+https://github.com/exeldro/$pkgname#commit=8d71fc5c6994cce68b912ae3c075e39415f982aa"
- "obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
-)
-sha256sums=(
- "SKIP"
- "412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8"
-)
+depends=("obs-studio>=28")
+makedepends=("cmake" "git")
+source=("$pkgname::git+https://github.com/exeldro/$pkgname#commit=4a543d3577d56a27f5f2b9aa541a466b37dafde0")
+sha256sums=("SKIP")
-prepare() {
- rm -rf fakeroot
-
- cd "obs-studio-$_obsver"/plugins
- cp -r "$srcdir/$pkgname" .
- sed -i 's|check_obs_browser()||g' CMakeLists.txt
- sed -i 's|FATAL_ERROR "obs-websocket|STATUS "obs-websocket|g' CMakeLists.txt
- echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
-}
-
-# Need to compile plugin in OBS compilation process
build() {
- cd "obs-studio-$_obsver"
+ cd "$pkgname"
cmake -B build \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DENABLE_UI=OFF \
- -DENABLE_WAYLAND=OFF \
- -DENABLE_PIPEWIRE=OFF \
- -DENABLE_SCRIPTING=OFF \
- -DENABLE_DECKLINK=OFF \
- -DENABLE_ALSA=OFF \
- -DENABLE_JACK=OFF \
- -DENABLE_PULSEAUDIO=OFF \
- -DENABLE_V4L2=OFF \
- -DENABLE_SPEEXDSP=OFF \
- -DENABLE_LIBFDK=OFF \
- -DENABLE_SNDIO=OFF \
- -DENABLE_FREETYPE=OFF \
- -DENABLE_VLC=OFF \
- -DENABLE_BROWSER=OFF \
- -DENABLE_VST=OFF \
- -DENABLE_RTMPS=OFF \
- -DENABLE_AJA=OFF \
- -DENABLE_NEW_MPEGTS_OUTPUT=OFF
+ -DLINUX_PORTABLE=OFF \
+ -DQT_VERSION=6
make -C build
}
package() {
- mkdir -p "$pkgdir"/usr/lib/obs-plugins
- mkdir -p "$pkgdir"/usr/share/obs/obs-plugins
-
- cd "obs-studio-$_obsver"
- make -C build DESTDIR="$srcdir/fakeroot/" install
- cp -a "$srcdir"/fakeroot/usr/lib/obs-plugins/$_pluginname.so "$pkgdir"/usr/lib/obs-plugins/
- cp -a "$srcdir"/fakeroot/usr/share/obs/obs-plugins/$_pluginname "$pkgdir"/usr/share/obs/obs-plugins/
-} \ No newline at end of file
+ cd "$pkgname"
+ make -C build DESTDIR="$pkgdir/" install
+}