summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-02-17 22:46:56 +0100
committertytan6522022-02-17 22:46:56 +0100
commitce1b7824d4b672ba5dacf585f0296a293a756db7 (patch)
tree3d08d530d7c8224039b527db2cdbcbe38514490e
parent0bc842a1481f228d485488f4057d86317987bfbc (diff)
downloadaur-ce1b7824d4b672ba5dacf585f0296a293a756db7.tar.gz
build: Fix build issue with ffmpeg4.4
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38b962b2478b..a5ecf9be93bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-source-record
pkgdesc = Plugin for OBS Studio to add a filter that allows you to record a source
pkgver = 0.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://obsproject.com/forum/resources/source-record.1285/
arch = i686
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = obs-source-record
makedepends = cmake
makedepends = git
makedepends = libxcomposite
- depends = obs-studio>=27.0.0
+ makedepends = ffmpeg
+ depends = obs-studio>=27.2.0
source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=91d3713871356a47c9a2743113d208c797a566fe
- source = obs-studio-27.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.0.0.tar.gz
+ source = obs-studio-27.2.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.2.0.tar.gz
sha256sums = SKIP
- sha256sums = c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e
+ sha256sums = c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789
pkgname = obs-source-record
diff --git a/PKGBUILD b/PKGBUILD
index 84b98d599c47..020d16f6534e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
_pluginname=source-record
pkgname=obs-$_pluginname
pkgver=0.2.7
-_obsver=27.0.0
-pkgrel=1
+_obsver=27.2.0
+pkgrel=2
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
license=("GPL2")
depends=("obs-studio>=$_obsver")
-makedepends=("cmake" "git" "libxcomposite")
+makedepends=("cmake" "git" "libxcomposite" "ffmpeg")
source=(
"$pkgname::git+https://github.com/exeldro/$pkgname#commit=91d3713871356a47c9a2743113d208c797a566fe"
"obs-studio-$_obsver.tar.gz::https://github.com/obsproject/obs-studio/archive/$_obsver.tar.gz"
)
sha256sums=(
"SKIP"
- "c7ea5369f4c94203a8a81b73c6372873f08ab9e5b20860691dad2c29f5dda85e"
+ "c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789"
)
prepare() {