summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-11-07 16:18:29 +0100
committertytan6522022-11-07 16:18:29 +0100
commite3aafec10572b7920fd5cbc48a15f5859a8913d4 (patch)
tree0bd77536f2d8b3a5e6f172918020def736396bcf
parent80d78d993367883475d516140daa4546acacc937 (diff)
downloadaur-e3aafec10572b7920fd5cbc48a15f5859a8913d4.tar.gz
build: Fix building with newer FFmpeg
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD38
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51626b69dd54..1ec7f81e1610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-source-record
pkgdesc = Plugin for OBS Studio to add a filter that allows you to record a source
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://obsproject.com/forum/resources/source-record.1285/
arch = i686
arch = x86_64
@@ -12,10 +12,10 @@ pkgbase = obs-source-record
makedepends = libxcomposite
makedepends = ffmpeg
makedepends = pciutils
- depends = obs-studio>=27.2.0
+ depends = obs-studio>=28.0.0
source = obs-source-record::git+https://github.com/exeldro/obs-source-record#commit=8d71fc5c6994cce68b912ae3c075e39415f982aa
- source = obs-studio-27.2.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.2.0.tar.gz
+ source = obs-studio-28.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/28.0.0.tar.gz
sha256sums = SKIP
- sha256sums = c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789
+ sha256sums = 412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8
pkgname = obs-source-record
diff --git a/PKGBUILD b/PKGBUILD
index 547bd40b24c3..c86bd542661d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pluginname=source-record
pkgname=obs-$_pluginname
pkgver=0.3.0
-_obsver=27.2.0
-pkgrel=1
+_obsver=28.0.0
+pkgrel=2
pkgdesc="Plugin for OBS Studio to add a filter that allows you to record a source"
arch=("i686" "x86_64" "aarch64")
url="https://obsproject.com/forum/resources/source-record.1285/"
@@ -17,7 +17,7 @@ source=(
)
sha256sums=(
"SKIP"
- "c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789"
+ "412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8"
)
prepare() {
@@ -25,6 +25,8 @@ prepare() {
cd "obs-studio-$_obsver"/plugins
cp -r "$srcdir/$pkgname" .
+ sed -i 's|check_obs_browser()||g' CMakeLists.txt
+ sed -i 's|FATAL_ERROR "obs-websocket|STATUS "obs-websocket|g' CMakeLists.txt
echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null
}
@@ -34,23 +36,25 @@ build() {
cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DDISABLE_UI=ON \
+ -DENABLE_UI=OFF \
-DENABLE_WAYLAND=OFF \
-DENABLE_PIPEWIRE=OFF \
-DENABLE_SCRIPTING=OFF \
- -DDISABLE_DECKLINK=ON \
- -DDISABLE_ALSA=ON \
- -DDISABLE_JACK=ON \
- -DDISABLE_PULSEAUDIO=ON \
- -DDISABLE_V4L2=ON \
- -DDISABLE_SPEEXDSP=ON \
- -DDISABLE_LIBFDK=ON \
- -DDISABLE_SNDIO=ON \
- -DDISABLE_FREETYPE=ON \
- -DDISABLE_VLC=ON \
- -DBUILD_BROWSER=OFF \
- -DBUILD_VST=OFF \
- -DWITH_RTMPS=OFF
+ -DENABLE_DECKLINK=OFF \
+ -DENABLE_ALSA=OFF \
+ -DENABLE_JACK=OFF \
+ -DENABLE_PULSEAUDIO=OFF \
+ -DENABLE_V4L2=OFF \
+ -DENABLE_SPEEXDSP=OFF \
+ -DENABLE_LIBFDK=OFF \
+ -DENABLE_SNDIO=OFF \
+ -DENABLE_FREETYPE=OFF \
+ -DENABLE_VLC=OFF \
+ -DENABLE_BROWSER=OFF \
+ -DENABLE_VST=OFF \
+ -DENABLE_RTMPS=OFF \
+ -DENABLE_AJA=OFF \
+ -DENABLE_NEW_MPEGTS_OUTPUT=OFF
make -C build
}