diff options
author | tytan652 | 2022-11-07 16:22:05 +0100 |
---|---|---|
committer | tytan652 | 2022-11-07 16:22:05 +0100 |
commit | 115160b5fed5dd85bb87f4ca06c9dd76bc76e565 (patch) | |
tree | 7d0269e0e5400898355a1f846d8582d5a2b3ebb4 | |
parent | b25cbc8177f79d91b4bacc1409adfc0f490ad076 (diff) | |
download | aur-115160b5fed5dd85bb87f4ca06c9dd76bc76e565.tar.gz |
build: Fix building with newer FFmpeg
-rw-r--r-- | .SRCINFO | 8 | ||||
-rw-r--r-- | PKGBUILD | 38 |
2 files changed, 25 insertions, 21 deletions
@@ -1,7 +1,7 @@ pkgbase = obs-source-switcher pkgdesc = Plugin for OBS Studio to add a source that switches between a list of sources pkgver = 0.4.0 - pkgrel = 3 + pkgrel = 4 url = https://obsproject.com/forum/resources/source-switcher.941/ arch = i686 arch = x86_64 @@ -12,10 +12,10 @@ pkgbase = obs-source-switcher makedepends = libxcomposite makedepends = ffmpeg makedepends = pciutils - depends = obs-studio>=27.2.0 + depends = obs-studio>=28.0.0 source = obs-source-switcher::git+https://github.com/exeldro/obs-source-switcher#commit=c83d7d2a497a4c7629e47508309a399a8b83aa06 - source = obs-studio-27.2.0.tar.gz::https://github.com/obsproject/obs-studio/archive/27.2.0.tar.gz + source = obs-studio-28.0.0.tar.gz::https://github.com/obsproject/obs-studio/archive/28.0.0.tar.gz sha256sums = SKIP - sha256sums = c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789 + sha256sums = 412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8 pkgname = obs-source-switcher @@ -3,8 +3,8 @@ _pluginname=source-switcher pkgname=obs-$_pluginname pkgver=0.4.0 -_obsver=27.2.0 -pkgrel=3 +_obsver=28.0.0 +pkgrel=4 pkgdesc="Plugin for OBS Studio to add a source that switches between a list of sources" arch=("i686" "x86_64" "aarch64") url="https://obsproject.com/forum/resources/source-switcher.941/" @@ -17,7 +17,7 @@ source=( ) sha256sums=( "SKIP" - "c52d99cba6c536cb805e3e0f54663c33cfc43a1b7521bec97d241019499f9789" + "412a1a26699a6861dbbe93346310d002369c62e00626e8c3a77c127e5e1c06e8" ) prepare() { @@ -25,6 +25,8 @@ prepare() { cd "obs-studio-$_obsver"/plugins cp -r "$srcdir/$pkgname" . + sed -i 's|check_obs_browser()||g' CMakeLists.txt + sed -i 's|FATAL_ERROR "obs-websocket|STATUS "obs-websocket|g' CMakeLists.txt echo "add_subdirectory($pkgname)" | tee -a CMakeLists.txt >/dev/null } @@ -34,23 +36,25 @@ build() { cmake -B build \ -DCMAKE_INSTALL_PREFIX=/usr \ -DCMAKE_INSTALL_LIBDIR=lib \ - -DDISABLE_UI=ON \ + -DENABLE_UI=OFF \ -DENABLE_WAYLAND=OFF \ -DENABLE_PIPEWIRE=OFF \ -DENABLE_SCRIPTING=OFF \ - -DDISABLE_DECKLINK=ON \ - -DDISABLE_ALSA=ON \ - -DDISABLE_JACK=ON \ - -DDISABLE_PULSEAUDIO=ON \ - -DDISABLE_V4L2=ON \ - -DDISABLE_SPEEXDSP=ON \ - -DDISABLE_LIBFDK=ON \ - -DDISABLE_SNDIO=ON \ - -DDISABLE_FREETYPE=ON \ - -DDISABLE_VLC=ON \ - -DBUILD_BROWSER=OFF \ - -DBUILD_VST=OFF \ - -DWITH_RTMPS=OFF + -DENABLE_DECKLINK=OFF \ + -DENABLE_ALSA=OFF \ + -DENABLE_JACK=OFF \ + -DENABLE_PULSEAUDIO=OFF \ + -DENABLE_V4L2=OFF \ + -DENABLE_SPEEXDSP=OFF \ + -DENABLE_LIBFDK=OFF \ + -DENABLE_SNDIO=OFF \ + -DENABLE_FREETYPE=OFF \ + -DENABLE_VLC=OFF \ + -DENABLE_BROWSER=OFF \ + -DENABLE_VST=OFF \ + -DENABLE_RTMPS=OFF \ + -DENABLE_AJA=OFF \ + -DENABLE_NEW_MPEGTS_OUTPUT=OFF make -C build } |