summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Denizart2023-07-08 22:55:27 +0200
committerHugo Denizart2023-07-08 22:55:27 +0200
commit30d1a6507d32cdc6a01e057de62759cbe603f9f2 (patch)
treea96486298923d34ec93d3d25797729e0654bab73
parentf7707aa74be28ed5007916b830aae8f65bb50fae (diff)
downloadaur-obs-streamfx-git.tar.gz
🐛 Upgrade to Qt 6, remove ffmpeg support patch
-rw-r--r--.SRCINFO6
-rw-r--r--00001-fix-build-on-ffmpeg-6.patch26
-rw-r--r--PKGBUILD11
3 files changed, 6 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b812baf0c614..5c3c1f6d4490 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-streamfx-git
pkgdesc = Bring your stream back to life with modern effects!
- pkgver = 0.12.0b191.r10.g5dfb8bca
+ pkgver = 0.12.0b299.r0.g8b97c2b2
pkgrel = 1
url = https://github.com/Xaymar/obs-StreamFX
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = obs-streamfx-git
depends = jansson
depends = libxinerama
depends = libxkbcommon-x11
- depends = qt5-x11extras
+ depends = qt6-base
depends = curl
depends = gtk-update-icon-cache
depends = obs-studio>=25
@@ -28,8 +28,6 @@ pkgbase = obs-streamfx-git
provides = obs-streamfx
conflicts = obs-streamfx
source = obs-streamfx-git::git+https://github.com/Xaymar/obs-StreamFX.git#branch=root
- source = 00001-fix-build-on-ffmpeg-6.patch
md5sums = SKIP
- md5sums = e532ab3c20aa2b40099706990ec92ba0
pkgname = obs-streamfx-git
diff --git a/00001-fix-build-on-ffmpeg-6.patch b/00001-fix-build-on-ffmpeg-6.patch
deleted file mode 100644
index 5bae53bbef53..000000000000
--- a/00001-fix-build-on-ffmpeg-6.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/source/encoders/encoder-ffmpeg.cpp b/source/encoders/encoder-ffmpeg.cpp
-index 1bfbc32c..43b05c48 100644
---- a/source/encoders/encoder-ffmpeg.cpp
-+++ b/source/encoders/encoder-ffmpeg.cpp
-@@ -1045,7 +1045,7 @@ void ffmpeg_factory::get_defaults2(obs_data_t* settings)
- if (_handler)
- _handler->get_defaults(settings, _avcodec, nullptr, _handler->is_hardware_encoder(this));
-
-- if ((_avcodec->capabilities & AV_CODEC_CAP_INTRA_ONLY) == 0) {
-+ if ((avcodec_descriptor_get(_avcodec->id)->props & AV_CODEC_PROP_INTRA_ONLY) == 0) {
- obs_data_set_default_int(settings, ST_KEY_KEYFRAMES_INTERVALTYPE, 0);
- obs_data_set_default_double(settings, ST_KEY_KEYFRAMES_INTERVAL_SECONDS, 2.0);
- obs_data_set_default_int(settings, ST_KEY_KEYFRAMES_INTERVAL_FRAMES, 300);
-diff --git a/source/encoders/handlers/handler.cpp b/source/encoders/handlers/handler.cpp
-index bb109dac..58199952 100644
---- a/source/encoders/handlers/handler.cpp
-+++ b/source/encoders/handlers/handler.cpp
-@@ -9,7 +9,7 @@ using namespace streamfx::encoder::ffmpeg;
-
- bool handler::handler::has_keyframe_support(ffmpeg_factory* instance)
- {
-- return (instance->get_avcodec()->capabilities & AV_CODEC_CAP_INTRA_ONLY) == 0;
-+ return (avcodec_descriptor_get(instance->get_avcodec()->id)->props & AV_CODEC_PROP_INTRA_ONLY) == 0;
- }
-
- bool handler::handler::is_hardware_encoder(ffmpeg_factory* instance)
diff --git a/PKGBUILD b/PKGBUILD
index e5aa42d72baf..1e8f9826b933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hugo Denizart <hugo at denizart dot pro>
pkgname=obs-streamfx-git
-pkgver=0.12.0b191.r10.g5dfb8bca
+pkgver=0.12.0b299.r0.g8b97c2b2
pkgrel=1
pkgdesc="Bring your stream back to life with modern effects!"
arch=("x86_64")
@@ -8,16 +8,14 @@ url="https://github.com/Xaymar/obs-StreamFX"
license=("GPL2")
# same dependencies as OBS Studio + nlohmann-json + ninja makedepends
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
- "qt5-x11extras" "curl" "gtk-update-icon-cache"
+ "qt6-base" "curl" "gtk-update-icon-cache"
"obs-studio>=25" "nlohmann-json")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
"vlc" "swig" "luajit" "python" "ninja")
provides=("obs-streamfx")
conflicts=("obs-streamfx")
-source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#branch=root"
- "00001-fix-build-on-ffmpeg-6.patch")
-md5sums=("SKIP"
- "e532ab3c20aa2b40099706990ec92ba0")
+source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#branch=root")
+md5sums=("SKIP")
pkgver() {
cd "$pkgname"
@@ -27,7 +25,6 @@ pkgver() {
prepare() {
cd $pkgname
git submodule update --init --recursive
- git apply ../00001-fix-build-on-ffmpeg-6.patch
}
build() {