summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Denizart2022-01-10 12:29:41 +0100
committerHugo Denizart2022-01-10 12:29:41 +0100
commit2406b7d5b26c8a36b57abc70077be9c7cbf4645f (patch)
treeba74271f935553fda631d6ba46dd53946836dcd7
parentfa080e8d9d44fc08624e79fbbb3482c160ccfa26 (diff)
downloadaur-2406b7d5b26c8a36b57abc70077be9c7cbf4645f.tar.gz
🔖 Release 0.11.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4699f9fc9fb1..2fce9585bedb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-streamfx
pkgdesc = Bring your stream back to life with modern effects!
- pkgver = 0.10.1
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/Xaymar/obs-StreamFX
arch = x86_64
@@ -24,8 +24,8 @@ pkgbase = obs-streamfx
depends = curl
depends = gtk-update-icon-cache
depends = obs-studio>=25
- source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.10.1
+ depends = nlohmann-json
+ source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.11.0
md5sums = SKIP
pkgname = obs-streamfx
-
diff --git a/PKGBUILD b/PKGBUILD
index c259503cfc25..a092434105f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Hugo Denizart <hugo at denizart dot pro>
pkgname=obs-streamfx
-pkgver=0.10.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="Bring your stream back to life with modern effects!"
arch=("x86_64")
url="https://github.com/Xaymar/obs-StreamFX"
license=("GPL2")
-# same dependencies as OBS Studio + ninja makedepends
+# same dependencies as OBS Studio + nlohmann-json + ninja makedepends
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
"qt5-x11extras" "curl" "gtk-update-icon-cache"
- "obs-studio>=25")
+ "obs-studio>=25" "nlohmann-json")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
"vlc" "swig" "luajit" "python" "ninja")
source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#tag="$pkgver)
@@ -23,7 +23,7 @@ prepare() {
build() {
cd $pkgname
- cmake -H. -B"build/flux" -G"Ninja" -DOBS_DOWNLOAD=ON -DCMAKE_PACKAGE_NAME=StreamFX -DCMAKE_PACKAGE_PREFIX="build/package" -DCMAKE_INSTALL_PREFIX="build/distrib" -DENABLE_UPDATER=FALSE -DCMAKE_CXX_COMPILER=g++ -DCMAKE_C_COMPILER=gcc
+ cmake -H. -B"build/flux" -G"Ninja" -DCMAKE_INSTALL_PREFIX="build/distrib" -DENABLE_UPDATER=FALSE -DCMAKE_CXX_COMPILER=g++ -DCMAKE_C_COMPILER=gcc
cmake --build "build/flux" --config RelWithDebInfo --target install
}