summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Denizart2021-04-26 15:14:20 +0200
committerHugo Denizart2021-04-26 15:14:20 +0200
commit3655a03f4ad763426e76f2cd3f81aa041cfa61b7 (patch)
tree3090cfce2b81f1c65e33545bbe9eba143eae38d1
parentcfc25c707c9645c50df8076611b5f5f3f21b1bf1 (diff)
downloadaur-3655a03f4ad763426e76f2cd3f81aa041cfa61b7.tar.gz
🔖 Release 0.10.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--fix_updater.patch38
3 files changed, 5 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e36fc727ff2..8980fdab323b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-streamfx
pkgdesc = Bring your stream back to life with modern effects!
- pkgver = 0.9.3
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/Xaymar/obs-StreamFX
arch = x86_64
@@ -24,10 +24,8 @@ pkgbase = obs-streamfx
depends = curl
depends = gtk-update-icon-cache
depends = obs-studio>=25
- source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.9.3
- source = fix_updater.patch::https://patch-diff.githubusercontent.com/raw/Xaymar/obs-StreamFX/pull/452.patch
+ source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.10.0
md5sums = SKIP
- md5sums = 0322447810b8871a4fc5da6099240876
pkgname = obs-streamfx
diff --git a/PKGBUILD b/PKGBUILD
index 48cf6bfb170c..5dcf96ac11b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hugo Denizart <hugo at denizart dot pro>
pkgname=obs-streamfx
-pkgver=0.9.3
+pkgver=0.10.0
pkgrel=1
pkgdesc="Bring your stream back to life with modern effects!"
arch=("x86_64")
@@ -12,15 +12,12 @@ depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
"obs-studio>=25")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
"vlc" "swig" "luajit" "python" "ninja")
-source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#tag="$pkgver
- fix_updater.patch::https://patch-diff.githubusercontent.com/raw/Xaymar/obs-StreamFX/pull/452.patch)
-md5sums=("SKIP"
- "0322447810b8871a4fc5da6099240876")
+source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#tag="$pkgver)
+md5sums=("SKIP")
prepare() {
cd $pkgname
git submodule update --init --recursive
- git apply ../fix_updater.patch
}
build() {
diff --git a/fix_updater.patch b/fix_updater.patch
deleted file mode 100644
index ef4a31e5e645..000000000000
--- a/fix_updater.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 072d129f542d60bfdc34efd882eb24e88131d99c Mon Sep 17 00:00:00 2001
-From: tytan652 <tytan652@tytanium.xyz>
-Date: Tue, 2 Feb 2021 21:48:17 +0100
-Subject: [PATCH] ui: Don't reference Updater if it's been disabled
-
-Merges #446
----
- source/ui/ui.cpp | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/source/ui/ui.cpp b/source/ui/ui.cpp
-index 78876eb5..d6034f4c 100644
---- a/source/ui/ui.cpp
-+++ b/source/ui/ui.cpp
-@@ -80,7 +80,11 @@ streamfx::ui::handler::handler()
-
- _about_action(), _about_dialog(),
-
-- _translator(), _updater()
-+ _translator()
-+#ifdef ENABLE_UPDATER
-+ ,
-+ _updater()
-+#endif
- {
- obs_frontend_add_event_callback(frontend_event_handler, this);
- }
-@@ -169,7 +173,10 @@ void streamfx::ui::handler::on_obs_loaded()
- }
-
- // Let the Updater start its work.
-+
-+#ifdef ENABLE_UPDATER
- this->_updater->obs_ready();
-+#endif
- }
-
- void streamfx::ui::handler::on_obs_exit()