summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2022-09-20 16:03:22 +0200
committerFrederik “Freso” S. Olesen2022-09-20 16:03:22 +0200
commit58a239d55b7244380cc906eb51b80a428934da32 (patch)
tree351d751ef73514d2c0545ec4a7fe23fb19b7614e
parentd8146c2e79c1f3a1ca424ba18039d55c7b96f94d (diff)
downloadaur-58a239d55b7244380cc906eb51b80a428934da32.tar.gz
obs-streamfx 0.12.0a134
https://github.com/Xaymar/obs-StreamFX/releases/tag/0.12.0a134
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 585db3fba60e..98f477b978b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = obs-streamfx
- pkgdesc = Bring your stream back to life with modern effects!
- pkgver = 0.11.1
+pkgbase = obs-streamfx-unstable
+ pkgdesc = Bring your stream back to life with modern effects! (unstable/testing version)
+ pkgver = 0.12.0a134
pkgrel = 1
url = https://github.com/Xaymar/obs-StreamFX
arch = x86_64
@@ -23,9 +23,11 @@ pkgbase = obs-streamfx
depends = qt5-x11extras
depends = curl
depends = gtk-update-icon-cache
- depends = obs-studio>=25
+ depends = obs-studio>=28
depends = nlohmann-json
- source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.11.1
+ provides = obs-streamfx
+ conflicts = obs-streamfx
+ source = obs-streamfx::git+https://github.com/Xaymar/obs-StreamFX.git#tag=0.12.0a134
md5sums = SKIP
-pkgname = obs-streamfx
+pkgname = obs-streamfx-unstable
diff --git a/PKGBUILD b/PKGBUILD
index e7745c5c6092..5078e352750f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
-# Maintainer: Hugo Denizart <hugo at denizart dot pro>
-pkgname=obs-streamfx
-pkgver=0.11.1
+# Maintainer: Frederik “Freso” S. Olesen <archlinux at freso.dk>
+# Contributor: Hugo Denizart <hugo at denizart dot pro>
+_pkgname=obs-streamfx
+pkgname=$_pkgname-unstable
+pkgver=0.12.0a134
pkgrel=1
-pkgdesc="Bring your stream back to life with modern effects!"
+pkgdesc="Bring your stream back to life with modern effects! (unstable/testing version)"
arch=("x86_64")
url="https://github.com/Xaymar/obs-StreamFX"
license=("GPL2")
# same dependencies as OBS Studio + nlohmann-json + ninja makedepends
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
"qt5-x11extras" "curl" "gtk-update-icon-cache"
- "obs-studio>=25" "nlohmann-json")
+ "obs-studio>=28" "nlohmann-json")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
"vlc" "swig" "luajit" "python" "ninja")
-source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#tag="$pkgver)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$_pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#tag="$pkgver)
md5sums=("SKIP")
prepare() {
- cd $pkgname
+ cd $_pkgname
git submodule update --init --recursive
}
build() {
- cd $pkgname
+ cd $_pkgname
cmake -H. -B"build/flux" -G"Ninja" -DCMAKE_INSTALL_PREFIX="build/distrib" -DENABLE_UPDATER=FALSE -DCMAKE_CXX_COMPILER=g++ -DCMAKE_C_COMPILER=gcc
@@ -29,7 +33,7 @@ build() {
}
package() {
- cd $pkgname/build/distrib/plugins/StreamFX
+ cd $_pkgname/build/distrib/plugins/StreamFX
install -D -m 755 bin/64bit/StreamFX.so $pkgdir/usr/lib/obs-plugins/StreamFX.so