summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Denizart2020-04-16 19:44:40 +0200
committerHugo Denizart2020-04-16 19:44:40 +0200
commitb8e22674775f7432a2c590d877343fcfd62fc77c (patch)
treed81969e5dae900215262c5a831cd9de2e613dc11
downloadaur-b8e22674775f7432a2c590d877343fcfd62fc77c.tar.gz
🎉 Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..492376631342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = obs-streamfx-git
+ pkgdesc = Bring your stream back to life with modern effects!
+ pkgver = 0.8.0b1.r1.gc03fc93
+ pkgrel = 1
+ url = https://github.com/Xaymar/obs-StreamFX
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = libfdk-aac
+ makedepends = libxcomposite
+ makedepends = x264
+ makedepends = jack
+ makedepends = vlc
+ makedepends = swig
+ makedepends = luajit
+ makedepends = python
+ depends = ffmpeg
+ depends = jansson
+ depends = libxinerama
+ depends = libxkbcommon-x11
+ depends = qt5-x11extras
+ depends = curl
+ depends = gtk-update-icon-cache
+ depends = obs-studio>=25
+ provides = obs-streamfx
+ conflicts = obs-streamfx
+ source = obs-streamfx-git::git+https://github.com/Xaymar/obs-StreamFX.git#branch=master
+ md5sums = SKIP
+
+pkgname = obs-streamfx-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00450ddbf92c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar*
+obs-streamfx-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2013b779acd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Hugo Denizart <hugo at denizart dot pro>
+pkgname=obs-streamfx-git
+pkgver=0.8.0b1.r1.gc03fc93
+pkgrel=1
+pkgdesc="Bring your stream back to life with modern effects!"
+arch=("x86_64")
+url="https://github.com/Xaymar/obs-StreamFX"
+license=("GPL2")
+# same dependencies as OBS Studio
+depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11"
+ "qt5-x11extras" "curl" "gtk-update-icon-cache"
+ "obs-studio>=25")
+makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264" "jack"
+ "vlc" "swig" "luajit" "python")
+provides=("obs-streamfx")
+conflicts=("obs-streamfx")
+source=("$pkgname::git+https://github.com/Xaymar/obs-StreamFX.git#branch=master")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ git submodule update --init --recursive
+}
+
+build() {
+ cd $pkgname
+
+ cmake -H. -B"build/flux" -G"Ninja" -DOBS_DOWNLOAD=ON -DCMAKE_PACKAGE_NAME=StreamFX -DCMAKE_PACKAGE_PREFIX="build/package" -DCMAKE_INSTALL_PREFIX="build/distrib" -DCMAKE_CXX_COMPILER=g++ -DCMAKE_C_COMPILER=gcc
+
+ cmake --build "build/flux" --config RelWithDebInfo --target install
+}
+
+package() {
+ cd $pkgname/build/distrib/plugins/StreamFX
+
+ install -D -m 755 bin/64bit/StreamFX.so $pkgdir/usr/lib/obs-plugins/StreamFX.so
+
+ mkdir -p $pkgdir/usr/share/obs/obs-plugins/StreamFX
+ cp -R data/* $pkgdir/usr/share/obs/obs-plugins/StreamFX
+ chmod 644 $pkgdir/usr/share/obs/obs-plugins/StreamFX/*/**/*
+}
+
+# vim: ts=2:sw=2:expandtab