summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Miguel Sarasola2023-06-20 08:26:05 +0200
committerJosé Miguel Sarasola2023-06-20 08:26:05 +0200
commitc9b08f8ff22a61c32dbd7654a6011bb8581c08d8 (patch)
tree5aa40146afcbf9d7c04dec2706f025ffeed496c4
parent9aef4a1c78bed18da8877f089b08b54d82b0a094 (diff)
downloadaur-c9b08f8ff22a61c32dbd7654a6011bb8581c08d8.tar.gz
Update to version 29.1.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 094f0c97e53b..9cf95323f3ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-studio-amf
pkgdesc = Free, open source software for live streaming and recording. Includes new AMF encoding patch & browser plugin
- pkgver = 29.1.2
+ pkgver = 29.1.3
pkgrel = 1
url = https://obsproject.com
arch = x86_64
@@ -41,12 +41,12 @@ pkgbase = obs-studio-amf
optdepends = python: scripting support
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: virtual camera support
- provides = obs-studio=29.1.2
+ provides = obs-studio=29.1.3
provides = obs-websocket
conflicts = obs-studio
conflicts = obs-studio-tytan652
conflicts = obs-websocket
- source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.2
+ source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.3
source = cef_binary_5060_linux64.tar.bz2::https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux64.tar.bz2
source = 7206.patch
source = com.obsproject.Studio.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 971d384c7fee..fba42f79f7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
# Contributor: Benjamin Klettbach <b.klettbach@gmail.com>
pkgname=obs-studio-amf
-pkgver=29.1.2
+pkgver=29.1.3
pkgrel=1
pkgdesc="Free, open source software for live streaming and recording. Includes new AMF encoding patch & browser plugin"
arch=('x86_64')
url="https://obsproject.com"
license=('GPL2')
depends=('ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls' 'rnnoise' 'pciutils' 'nss'
- 'qt6-svg' 'qt6-wayland' 'xdg-desktop-portal' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite' 'amf-amdgpu-pro')
+ 'qt6-svg' 'qt6-wayland' 'xdg-desktop-portal' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite' 'amf-amdgpu-pro')
makedepends=('cmake' 'libfdk-aac' 'x264' 'swig' 'python' 'luajit' 'sndio' 'git' 'nlohmann-json' 'websocketpp' 'asio' 'amf-headers')
provides=("obs-studio=$pkgver" "obs-websocket")
conflicts=("obs-studio" "obs-studio-tytan652" "obs-websocket")
optdepends=('libfdk-aac: FDK AAC codec support'
- 'libva-intel-driver: hardware encoding'
- 'libva-mesa-driver: hardware encoding'
- 'luajit: scripting support'
- 'python: scripting support'
- 'sndio: Sndio input client'
- 'v4l2loopback-dkms: virtual camera support')
+ 'libva-intel-driver: hardware encoding'
+ 'libva-mesa-driver: hardware encoding'
+ 'luajit: scripting support'
+ 'python: scripting support'
+ 'sndio: Sndio input client'
+ 'v4l2loopback-dkms: virtual camera support')
source=(obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver
cef_binary_5060_linux64.tar.bz2::https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux64.tar.bz2
7206.patch
@@ -34,22 +34,23 @@ prepare() {
tar -xjf ./cef_binary_5060_linux64.tar.bz2
cd obs-studio
git submodule update --init --recursive
- patch -Np1 < "$srcdir"/7206.patch
+ patch -Np1 <"$srcdir"/7206.patch
}
build() {
cd obs-studio
- mkdir -p build; cd build
+ mkdir -p build
+ cd build
cmake -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_VST=ON \
- -DENABLE_VLC=OFF \
- -DENABLE_BROWSER=ON \
- -DCEF_ROOT_DIR="../../cef_binary_5060_linux64" \
- -DENABLE_AJA=OFF \
- -DENABLE_JACK=ON \
- -DENABLE_NEW_MPEGTS_OUTPUT=OFF \
- -DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
+ -DENABLE_VST=ON \
+ -DENABLE_VLC=OFF \
+ -DENABLE_BROWSER=ON \
+ -DCEF_ROOT_DIR="../../cef_binary_5060_linux64" \
+ -DENABLE_AJA=OFF \
+ -DENABLE_JACK=ON \
+ -DENABLE_NEW_MPEGTS_OUTPUT=OFF \
+ -DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
make
}