summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Steel2022-09-24 08:28:41 +0000
committerJonathan Steel2022-09-24 08:28:41 +0000
commitffcb65976bcead819fdc29cc3cbf3914995617fa (patch)
tree313868774e3b9fcdc2202da85c9fe00efc4b13b9
parent8e1f46df6a85b2b5538beb98b63f64755c07c87f (diff)
downloadaur-ffcb65976bcead819fdc29cc3cbf3914995617fa.tar.gz
upgpkg: 28.0.2-1
-rw-r--r--PKGBUILD23
-rw-r--r--ignore_unused_submodules.patch19
2 files changed, 33 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 461f234c97e2..577bd7d0d10d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Benjamin Klettbach <b.klettbach@gmail.com>
pkgname=obs-studio
-pkgver=27.2.4
-pkgrel=2
+pkgver=28.0.2
+pkgrel=1
pkgdesc="Free, open source software for live streaming and recording"
arch=('x86_64')
url="https://obsproject.com"
license=('GPL2')
depends=('ffmpeg' 'jansson' 'libxinerama' 'libxkbcommon-x11' 'mbedtls' 'rnnoise' 'pciutils'
- 'qt5-svg' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite')
+ 'qt6-svg' 'curl' 'jack' 'gtk-update-icon-cache' 'pipewire' 'libxcomposite')
makedepends=('cmake' 'libfdk-aac' 'x264' 'swig' 'python' 'luajit' 'sndio')
optdepends=('libfdk-aac: FDK AAC codec support'
'libva-intel-driver: hardware encoding'
@@ -19,13 +19,16 @@ optdepends=('libfdk-aac: FDK AAC codec support'
'sndio: Sndio input client'
'v4l2loopback-dkms: virtual camera support')
source=($pkgname-$pkgver.tar.gz::https://github.com/jp9000/obs-studio/archive/$pkgver.tar.gz
- fix_python_binary_loading.patch)
-md5sums=('a79f8bf28ab9995e333fc1ac0bcfa708'
- '051b90f05e26bff99236b8fb1ad377d1')
+ fix_python_binary_loading.patch
+ ignore_unused_submodules.patch)
+md5sums=('748258d94e9cfadc24af82d57fe24d66'
+ '051b90f05e26bff99236b8fb1ad377d1'
+ 'a898a94ad62d9d029c63f1d1379515d5')
prepare() {
cd $pkgname-$pkgver
patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
+ patch -Np1 < "$srcdir"/ignore_unused_submodules.patch
}
build() {
@@ -34,9 +37,11 @@ build() {
mkdir -p build; cd build
cmake -DCMAKE_INSTALL_PREFIX="/usr" \
- -DBUILD_BROWSER=OFF \
- -DBUILD_VST=OFF \
- -DDISABLE_VLC=ON \
+ -DENABLE_BROWSER=OFF \
+ -DENABLE_VST=OFF \
+ -DENABLE_VLC=OFF \
+ -DENABLE_NEW_MPEGTS_OUTPUT=OFF \
+ -DENABLE_AJA=OFF \
-DOBS_VERSION_OVERRIDE="$pkgver-$pkgrel" ..
make
diff --git a/ignore_unused_submodules.patch b/ignore_unused_submodules.patch
new file mode 100644
index 000000000000..bf84758b9bc2
--- /dev/null
+++ b/ignore_unused_submodules.patch
@@ -0,0 +1,19 @@
+--- a/plugins/CMakeLists.txt.orig 2022-09-24 09:05:46.308250388 +0100
++++ b/plugins/CMakeLists.txt 2022-09-24 09:06:04.978206849 +0100
+@@ -61,7 +61,6 @@
+ add_subdirectory(sndio)
+ add_subdirectory(obs-vst)
+
+- check_obs_browser()
+ elseif(OS_FREEBSD)
+ add_subdirectory(linux-capture)
+ add_subdirectory(linux-pulseaudio)
+@@ -84,8 +83,6 @@
+
+ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/obs-websocket/CMakeLists.txt)
+ add_subdirectory(obs-websocket)
+-else()
+- obs_status(FATAL_ERROR "obs-websocket submodule not available.")
+ endif()
+
+ add_subdirectory(image-source)