summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-10-19 17:05:10 +0200
committertytan6522022-10-19 17:05:10 +0200
commit17a9b65722fd1443c72cd9a3452149a79f98ba58 (patch)
treec86c464a17fb24cdbbcea6ebfc1fe0691537fd8d
parentc0eabe296f8ff4942099deae0967d31a39f2f83d (diff)
downloadaur-17a9b65722fd1443c72cd9a3452149a79f98ba58.tar.gz
build: Fix git CVE mess second try
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81979252d4b9..55072f914548 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integration
pkgver = 28.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/obsproject/obs-studio
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 40ae1413175b..440e5a658c4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-browser
pkgver=28.0.3
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -121,10 +121,9 @@ fi
prepare() {
cd "$srcdir/obs-studio"
- git config --local protocol.file.allow always
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
- git submodule update
+ git -c protocol.file.allow=always submodule update
cd plugins/obs-websocket
sed -i 's|EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/json/CMakeLists.txt||' CMakeLists.txt
@@ -132,9 +131,8 @@ prepare() {
sed -i 's|AND EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/asio/asio/include/asio.hpp||' CMakeLists.txt
sed -i "s|AND EXISTS|EXISTS|" CMakeLists.txt
sed -i "s|add_subdirectory(deps/json)|find_package(nlohmann_json 3.10.0 REQUIRED)|" CMakeLists.txt
- git config --local protocol.file.allow always
git config submodule.deps/qr.url $srcdir/qr
- git submodule update deps/qr
+ git -c protocol.file.allow=always submodule update deps/qr
}
build() {