summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-07 12:02:21 +0200
committertytan6522022-09-07 12:02:21 +0200
commit18d09beec25cfb5f1a55a9a500ba7b5e95f22116 (patch)
tree54ba572430a58f087b812ba78f700b359c0ed606
parent942b5d2ca3c03b37116ef0b66d91a631f15c8675 (diff)
downloadaur-18d09beec25cfb5f1a55a9a500ba7b5e95f22116.tar.gz
build: Re-use cef-minimal-obs package
I finally found the issue, revert the previous commit since doing that also fix the previous issue
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc4b84e86e5c..c7edc003d5f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integration
pkgver = 28.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/obsproject/obs-studio
arch = x86_64
license = GPL3
@@ -34,6 +34,7 @@ pkgbase = obs-studio-browser
depends = ffmpeg-obs>=5
depends = vlc-luajit
depends = ftl-sdk
+ depends = cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
depends = mbedtls
optdepends = libfdk-aac: FDK AAC codec support
optdepends = intel-media-driver: Hardware encoding (>= Broadwell)
@@ -55,16 +56,14 @@ pkgbase = obs-studio-browser
conflicts = obs-websocket
conflicts = obs-browser
conflicts = obs-linuxbrowser
- options = !strip
+ options = debug
source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=28.0.1
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
- source = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux64.tar.bz2
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d
pkgname = obs-studio-browser
diff --git a/PKGBUILD b/PKGBUILD
index a2c8cd4ce8ea..d04020a12e91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-browser
pkgver=28.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -37,6 +37,8 @@ depends=(
# AUR Packages
"ffmpeg-obs>=5" "vlc-luajit" "ftl-sdk"
+
+ "cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1"
)
# To manage mbedtls rebuild easily, this will prevent you to rebuild OBS on non-updated system
# For Manjaro user this feature is disabled
@@ -91,21 +93,19 @@ else
fi
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket" "obs-browser")
conflicts=("obs-studio" "obs-vst" "obs-websocket" "obs-browser" "obs-linuxbrowser")
-options=('!strip')
+options=('debug')
_cefbranch=5060
source=(
"obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
"obs-websocket::git+https://github.com/obsproject/obs-websocket.git"
"qr::git+https://github.com/nayuki/QR-Code-generator.git"
- "https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux64.tar.bz2"
)
sha256sums=(
"SKIP"
"SKIP"
"SKIP"
"SKIP"
- "ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d"
)
if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
@@ -136,14 +136,6 @@ prepare() {
}
build() {
- cd "$srcdir"/cef_binary_${_cefbranch}_linux64
-
- #The arm64 CEF set the wrong arch for the project
- cmake \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo .
-
- make libcef_dll_wrapper
-
cd "$srcdir"/obs-studio
mkdir -p build; cd build
@@ -156,7 +148,7 @@ build() {
-DENABLE_LIBFDK=ON \
-DENABLE_JACK=ON \
-DENABLE_SNDIO=ON \
- -DCEF_ROOT_DIR="$srcdir/cef_binary_${_cefbranch}_linux64" \
+ -DCEF_ROOT_DIR=/opt/cef-obs \
-DOBS_VERSION_OVERRIDE="$pkgver-browser-$pkgrel" ..
make