summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-04 10:16:27 +0200
committertytan6522023-05-04 10:16:27 +0200
commit4015cbcf7f688eeecacdc86e7e433d6f04f6bf92 (patch)
treee921c1ac55c6ae0053ff8b6c17e04033adef3f6c
parent438d75bad13e9a72db8ec204c61f9418cc090f4b (diff)
downloadaur-4015cbcf7f688eeecacdc86e7e433d6f04f6bf92.tar.gz
build: GCC 13 and Python 3.11
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix_build_with_GCC_13.patch36
-rw-r--r--PKGBUILD9
3 files changed, 48 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9389faf42693..23f1390c6355 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integration
pkgver = 29.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
@@ -12,7 +12,7 @@ pkgbase = obs-studio-browser
makedepends = swig
makedepends = luajit
makedepends = sndio
- makedepends = python>=3.10
+ makedepends = python>=3.11
makedepends = asio
makedepends = nlohmann-json
makedepends = websocketpp
@@ -42,7 +42,7 @@ pkgbase = obs-studio-browser
optdepends = libva-mesa-driver: Hardware encoding
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
- optdepends = python>=3.10: Python scripting
+ optdepends = python>=3.11: Python scripting
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = libajantv2: AJA NTV 2 support
@@ -62,9 +62,11 @@ pkgbase = obs-studio-browser
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
+ source = 0001-Fix_build_with_GCC_13.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 450cbf6df2b14ec8f9c43c1c7d4b06ab1b10c38eae6d1048eebffb4ca16e569
pkgname = obs-studio-browser
diff --git a/0001-Fix_build_with_GCC_13.patch b/0001-Fix_build_with_GCC_13.patch
new file mode 100644
index 000000000000..f1b60602b0e6
--- /dev/null
+++ b/0001-Fix_build_with_GCC_13.patch
@@ -0,0 +1,36 @@
+From 16aa55071f29c9e90d7b08ddd2e61fb6d5561f15 Mon Sep 17 00:00:00 2001
+From: tytan652 <tytan652@tytanium.xyz>
+Date: Thu, 4 May 2023 09:57:19 +0200
+Subject: [PATCH] obs-ffmpeg,obs-outputs: Fix maybe-unintialized warnings on
+ GCC 13
+
+---
+ plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c | 2 +-
+ plugins/obs-outputs/librtmp/rtmp.c | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
+index a3c4f925c607d..c454410a76295 100644
+--- a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
++++ b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
+@@ -727,7 +727,7 @@ static void *ffmpeg_mux_io_thread(void *data)
+ // ffmpeg, then we flush the chunk. next_seek_position is the actual
+ // offset we should seek to when we write the chunk.
+ uint64_t current_seek_position = 0;
+- uint64_t next_seek_position;
++ uint64_t next_seek_position = 0;
+
+ for (;;) {
+ // Wait for ffmpeg to write data to the buffer
+diff --git a/plugins/obs-outputs/librtmp/rtmp.c b/plugins/obs-outputs/librtmp/rtmp.c
+index 28239cb0351c8..7d0e6db7e0594 100644
+--- a/plugins/obs-outputs/librtmp/rtmp.c
++++ b/plugins/obs-outputs/librtmp/rtmp.c
+@@ -4556,6 +4556,7 @@ DecodeTEA(AVal *key, AVal *text)
+ /* prep text: hex2bin, multiples of 4 */
+ n = (text->av_len + 7) / 8;
+ out = malloc(n * 8);
++ memset(out, 0, n * 8);
+ ptr = (unsigned char *)text->av_val;
+ v = (uint32_t *) out;
+ for (i = 0; i < n; i++)
diff --git a/PKGBUILD b/PKGBUILD
index c2e8a796dcc4..7bb594d23115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,14 @@
pkgname=obs-studio-browser
pkgver=29.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL3")
# To manage dependency rebuild easily, this will prevent you to rebuild OBS on non-updated system
_mbedtlsver=2.28
-_pythonver=3.10
+_pythonver=3.11
depends=(
"jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils" "qt6-svg"
"mbedtls>=$_mbedtlsver"
@@ -82,12 +82,14 @@ source=(
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
"obs-websocket::git+https://github.com/obsproject/obs-websocket.git"
"qr::git+https://github.com/nayuki/QR-Code-generator.git"
+ "0001-Fix_build_with_GCC_13.patch"
)
sha256sums=(
"SKIP"
"SKIP"
"SKIP"
"SKIP"
+ "450cbf6df2b14ec8f9c43c1c7d4b06ab1b10c38eae6d1048eebffb4ca16e569"
)
if [[ $CARCH == 'x86_64' ]]; then
@@ -103,6 +105,9 @@ prepare() {
cd plugins/obs-websocket
git config submodule.deps/qr.url $srcdir/qr
git -c protocol.file.allow=always submodule update deps/qr
+
+ cd "$srcdir/obs-studio"
+ patch -Np1 < "$srcdir/0001-Fix_build_with_GCC_13.patch"
}
build() {