summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlice Gaudon2021-06-02 13:02:11 +0200
committerAlice Gaudon2021-06-02 13:02:11 +0200
commit8197a2a7561fdc0feafac3127ebcfec9a8862d5d (patch)
tree3380cbde80c44d7d4d851241afe26ae5254d3149
parent833034bc9dd795e569ba2239a9a925b811ba22d4 (diff)
downloadaur-8197a2a7561fdc0feafac3127ebcfec9a8862d5d.tar.gz
Add dlopen patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix_python_binary_loading.patch24
3 files changed, 33 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bcb7a57a40f..a1105b36d7e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
pkgdesc = Free and open source software for video recording and live streaming. Built with browser, vst plugins.
pkgver = 27.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -46,9 +46,11 @@ pkgbase = obs-studio-browser
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
source = git+https://github.com/obsproject/obs-vst.git
+ source = fix_python_binary_loading.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = 93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177
pkgname = obs-studio-browser
diff --git a/PKGBUILD b/PKGBUILD
index 1cc3c637a9f8..d75d1e88267c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=obs-studio-browser
pkgver=27.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="Free and open source software for video recording and live streaming. Built with browser, vst plugins."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -31,14 +31,17 @@ conflicts=("obs-studio" "obs-linuxbrowser")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
- "git+https://github.com/obsproject/obs-vst.git")
+ "git+https://github.com/obsproject/obs-vst.git"
+ "fix_python_binary_loading.patch")
sha512sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177')
prepare() {
cd $pkgname
+ patch -Np1 < "$srcdir"/fix_python_binary_loading.patch
git config submodule.plugins/obs-outputs/ftl-sdk.url "$srcdir"/ftl-sdk
git config submodule.plugins/obs-browser.url "$srcdir"/obs-browser
git config submodule.plugins/obs-vst.url "$srcdir"/obs-vst
diff --git a/fix_python_binary_loading.patch b/fix_python_binary_loading.patch
new file mode 100644
index 000000000000..6cba55f2f1af
--- /dev/null
+++ b/fix_python_binary_loading.patch
@@ -0,0 +1,24 @@
+From c482159ce93deafc7f1fc5755ba15135709ae726 Mon Sep 17 00:00:00 2001
+From: Matt Gajownik <matt@obsproject.com>
+Date: Tue, 25 Aug 2020 19:28:26 +1000
+Subject: [PATCH] libobs/util: Fix loading Python binary modules on *nix
+
+Fixes #2222
+---
+ libobs/util/platform-nix.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libobs/util/platform-nix.c b/libobs/util/platform-nix.c
+index 26800d52f7..997b62db1a 100644
+--- a/libobs/util/platform-nix.c
++++ b/libobs/util/platform-nix.c
+@@ -71,7 +71,8 @@ void *os_dlopen(const char *path)
+ #ifdef __APPLE__
+ void *res = dlopen(dylib_name.array, RTLD_LAZY | RTLD_FIRST);
+ #else
+- void *res = dlopen(dylib_name.array, RTLD_LAZY);
++ void *res = dlopen(dylib_name.array,
++ RTLD_LAZY | RTLD_DEEPBIND | RTLD_GLOBAL);
+ #endif
+ if (!res)
+ blog(LOG_ERROR, "os_dlopen(%s->%s): %s\n", path,