summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlice Gaudon2021-03-24 12:01:57 +0100
committerAlice Gaudon2021-03-24 12:06:24 +0100
commitc57a44be8f2be3bfae0fed56f76cd65368881426 (patch)
tree309bb2684b6836d248672a2bfb6459b3a8d7526c
parent8678a8174f706d39755f1442a26ebdd6de21d88a (diff)
downloadaur-c57a44be8f2be3bfae0fed56f76cd65368881426.tar.gz
Add obs-vst submodule
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df26927d14df..235dd8ab03c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
- pkgdesc = Free and open source software for video recording and live streaming. Built with the browser plugin.
+ pkgdesc = Free and open source software for video recording and live streaming. Built with browser, vst plugins.
pkgver = 26.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -38,6 +38,8 @@ pkgbase = obs-studio-browser
source = obs-studio-browser::git+https://github.com/obsproject/obs-studio.git#tag=26.1.1
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
+ source = git+https://github.com/obsproject/obs-vst.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 683e3a442cde..e4ce4f13bf9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-browser
pkgver=26.1.1
-pkgrel=2
-pkgdesc="Free and open source software for video recording and live streaming. Built with the browser plugin."
+pkgrel=3
+pkgdesc="Free and open source software for video recording and live streaming. Built with browser, vst plugins."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
@@ -26,13 +26,15 @@ provides=("obs-studio=$pkgver")
conflicts=("obs-studio" "obs-linuxbrowser")
source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
- "git+https://github.com/obsproject/obs-browser.git")
-md5sums=("SKIP" "SKIP" "SKIP")
+ "git+https://github.com/obsproject/obs-browser.git"
+ "git+https://github.com/obsproject/obs-vst.git")
+md5sums=("SKIP" "SKIP" "SKIP" "SKIP")
prepare() {
cd $pkgname
git config submodule.plugins/obs-outputs/ftl-sdk.url $srcdir/ftl-sdk
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
+ git config submodule.plugins/obs-vst.url $srcdir/obs-vst
git submodule update
}