summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlice Gaudon2022-02-16 13:03:22 +0100
committerAlice Gaudon2022-02-16 13:03:22 +0100
commitfeaecbfbe6113f5bb76e2942cd318eed5124bdd5 (patch)
treee88600faceceff9e991d22932e262d3fa3c80b36
parentfb983c99cc6bde95a1f38f8c84c4e456f6da6bcc (diff)
downloadaur-feaecbfbe6113f5bb76e2942cd318eed5124bdd5.tar.gz
Update to 27.2.0, switch to cef-minimal-obs, remove cef91.patch
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
-rw-r--r--cef91.patch61
3 files changed, 11 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5c0d5c97079..7e7c8caa5334 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-browser
pkgdesc = Free and open source software for video recording and live streaming. Built with browser, vst plugins.
- pkgver = 27.1.3
- pkgrel = 2
+ pkgver = 27.2.0
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -14,8 +14,7 @@ pkgbase = obs-studio-browser
makedepends = swig
makedepends = luajit
makedepends = python
- makedepends = cef-minimal>=91.0.0
- makedepends = cef-minimal<95.0.0
+ makedepends = cef-minimal-obs
makedepends = wayland
makedepends = qt5-wayland
makedepends = sndio
@@ -40,20 +39,18 @@ pkgbase = obs-studio-browser
optdepends = python: Python scripting
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: Virtual camera output
- provides = obs-studio=27.1.3
+ provides = obs-studio=27.2.0
conflicts = obs-studio
conflicts = obs-linuxbrowser
- source = obs-studio-browser::git+https://github.com/obsproject/obs-studio.git#tag=27.1.3
+ source = obs-studio-browser::git+https://github.com/obsproject/obs-studio.git#tag=27.2.0
source = git+https://github.com/Mixer/ftl-sdk.git
source = git+https://github.com/obsproject/obs-browser.git
source = git+https://github.com/obsproject/obs-vst.git
source = fix_python_binary_loading.patch
- source = cef91.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177
- sha512sums = b9e590190558648b34c0918f3e763c226aebfba543b547f0c7897dcaa2af23a9bc11493b6bc50dd23619b3992338e75ab4bed29e7b6e02f7e462ffbfb4905c38
pkgname = obs-studio-browser
diff --git a/PKGBUILD b/PKGBUILD
index 5eb2cedc19bd..4a678e887050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: ledti <antergist at gmail dot com>
pkgname=obs-studio-browser
-pkgver=27.1.3
-pkgrel=2
+pkgver=27.2.0
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming. Built with browser, vst plugins."
arch=("i686" "x86_64")
url="https://github.com/obsproject/obs-studio"
@@ -15,7 +15,7 @@ depends=("ffmpeg" "jack" "jansson" "libxinerama" "libxkbcommon-x11"
"qt5-svg" "qt5-x11extras" "curl" "gtk-update-icon-cache" "mbedtls"
"pipewire" "libxcomposite")
makedepends=("cmake" "git" "libfdk-aac" "x264"
- "vlc-luajit" "swig" "luajit" "python" "cef-minimal>=91.0.0" "cef-minimal<95.0.0"
+ "vlc-luajit" "swig" "luajit" "python" "cef-minimal-obs"
"wayland" "qt5-wayland" "sndio")
optdepends=("libfdk-aac: FDK AAC codec support"
"libva-intel-driver: Hardware encoding"
@@ -32,14 +32,12 @@ source=("$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"git+https://github.com/Mixer/ftl-sdk.git"
"git+https://github.com/obsproject/obs-browser.git"
"git+https://github.com/obsproject/obs-vst.git"
- "fix_python_binary_loading.patch"
- "cef91.patch")
+ "fix_python_binary_loading.patch")
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177'
- 'b9e590190558648b34c0918f3e763c226aebfba543b547f0c7897dcaa2af23a9bc11493b6bc50dd23619b3992338e75ab4bed29e7b6e02f7e462ffbfb4905c38')
+ '93ad704cef425073b417d1ed95e076f688a6e45cdf589472c65e437d77297303f31dd8f15c7d5e30f83276a6396b732dfb5a695db9c773911aaa0423c5262177')
prepare() {
cd "$srcdir/$pkgname"
@@ -48,7 +46,6 @@ prepare() {
git config submodule.plugins/obs-browser.url "$srcdir"/obs-browser
git config submodule.plugins/obs-vst.url "$srcdir"/obs-vst
git submodule update
- patch -d "$srcdir/$pkgname/plugins/obs-browser" -Np1 < "$srcdir"/cef91.patch
}
build() {
@@ -60,7 +57,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_BROWSER=ON \
- -DCEF_ROOT_DIR="/opt/cef" \
+ -DCEF_ROOT_DIR="/opt/cef-obs" \
-DOBS_VERSION_OVERRIDE=$pkgver ..
make
diff --git a/cef91.patch b/cef91.patch
deleted file mode 100644
index c8fd75db2210..000000000000
--- a/cef91.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/browser-app.cpp b/browser-app.cpp
-index f0aba74..df16c0a 100644
---- a/browser-app.cpp
-+++ b/browser-app.cpp
-@@ -117,7 +117,7 @@ void BrowserApp::OnContextCreated(CefRefPtr<CefBrowser> browser,
- {
- CefRefPtr<CefV8Value> globalObj = context->GetGlobal();
-
-- CefRefPtr<CefV8Value> obsStudioObj = CefV8Value::CreateObject(0, 0);
-+ CefRefPtr<CefV8Value> obsStudioObj = CefV8Value::CreateObject(nullptr, nullptr);
- globalObj->SetValue("obsstudio", obsStudioObj,
- V8_PROPERTY_ATTRIBUTE_NONE);
-
-@@ -154,7 +154,7 @@ void BrowserApp::ExecuteJSFunction(CefRefPtr<CefBrowser> browser,
- CefRefPtr<CefV8Value> jsFunction = obsStudioObj->GetValue(functionName);
-
- if (jsFunction && jsFunction->IsFunction())
-- jsFunction->ExecuteFunction(NULL, arguments);
-+ jsFunction->ExecuteFunction(nullptr, arguments);
-
- context->Exit();
- }
-@@ -310,7 +310,7 @@ bool BrowserApp::OnProcessMessageReceived(CefRefPtr<CefBrowser> browser,
-
- CefRefPtr<CefV8Value> dispatchEvent =
- globalObj->GetValue("dispatchEvent");
-- dispatchEvent->ExecuteFunction(NULL, arguments);
-+ dispatchEvent->ExecuteFunction(nullptr, arguments);
-
- context->Exit();
-
-@@ -340,7 +340,7 @@ bool BrowserApp::OnProcessMessageReceived(CefRefPtr<CefBrowser> browser,
- args.push_back(retval);
-
- if (callback)
-- callback->ExecuteFunction(NULL, args);
-+ callback->ExecuteFunction(nullptr, args);
-
- context->Exit();
-
-diff --git a/obs-browser-source.cpp b/obs-browser-source.cpp
-index 113a9f6..abac2a5 100644
---- a/obs-browser-source.cpp
-+++ b/obs-browser-source.cpp
-@@ -178,12 +178,15 @@ bool BrowserSource::CreateBrowser()
- cefBrowserSettings.default_font_size = 16;
- cefBrowserSettings.default_fixed_font_size = 16;
-
-+#if CHROME_VERSION_BUILD < 4430
- #if ENABLE_LOCAL_FILE_URL_SCHEME
- if (is_local) {
- /* Disable web security for file:// URLs to allow
-- * local content access to remote APIs */
-+ * local content access to remote APIs
-+ * This flag was removed from CEF >= 91 */
- cefBrowserSettings.web_security = STATE_DISABLED;
- }
-+#endif
- #endif
-
- cefBrowser = CefBrowserHost::CreateBrowserSync(