summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-03-09 17:11:33 +0100
committertytan6522023-03-09 17:11:33 +0100
commit056c848dfaf9e27ee22457cddb426ca723d6f8ff (patch)
tree6c006197a85d665ac34b53438327d68e61719491
parenta87580aeac816111f48d74ada8217c4e0109c616 (diff)
downloadaur-056c848dfaf9e27ee22457cddb426ca723d6f8ff.tar.gz
build: FFmpeg 6 rebuild
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD54
-rw-r--r--obs-studio-rc.hook10
-rwxr-xr-xobs-studio-rc.sh20
4 files changed, 15 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acdc0f8b897d..34615aadd950 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-rc
pkgdesc = Beta cycle of the free and open source software for video recording and live streaming. With everything except service integration
pkgver = 29.0.2
- pkgrel = 1
+ pkgrel = 2
epoch = 5
url = https://github.com/obsproject/obs-studio
arch = x86_64
@@ -13,12 +13,11 @@ pkgbase = obs-studio-rc
makedepends = swig
makedepends = luajit
makedepends = sndio
- makedepends = lsb-release
+ makedepends = python>=3.10
makedepends = asio
makedepends = nlohmann-json
makedepends = websocketpp
makedepends = libajantv2
- makedepends = python
makedepends = cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
depends = jack
depends = gtk-update-icon-cache
@@ -26,6 +25,7 @@ pkgbase = obs-studio-rc
depends = rnnoise
depends = pciutils
depends = qt6-svg
+ depends = mbedtls>=2.28
depends = qt6-wayland
depends = libxcomposite
depends = pipewire
@@ -34,20 +34,19 @@ pkgbase = obs-studio-rc
depends = libxrandr
depends = nss
depends = at-spi2-core
- depends = ffmpeg-obs>=5
+ depends = ffmpeg-obs>=6
depends = vlc-luajit
depends = ftl-sdk
- depends = mbedtls
optdepends = libfdk-aac: FDK AAC codec support
optdepends = intel-media-driver: Hardware encoding (>= Broadwell)
optdepends = libva-intel-driver: Hardware encoding (<= Haswell)
optdepends = libva-mesa-driver: Hardware encoding
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
+ optdepends = python>=3.10: Python scripting
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = libajantv2: AJA NTV 2 support
- optdepends = python: Python scripting
optdepends = decklink: Blackmagic Design DeckLink support
provides = obs-studio=29.0.2
provides = obs-vst
diff --git a/PKGBUILD b/PKGBUILD
index 2ef436353dc8..09a442b2f71f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
-DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
-
pkgname=obs-studio-rc
_pkgver=29.0.2
pkgver=${_pkgver//-/_}
-pkgrel=1
+pkgrel=2
epoch=5
pkgdesc="Beta cycle of the free and open source software for video recording and live streaming. With everything except service integration"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL3")
+# To manage dependency rebuild easily, this will prevent you to rebuild OBS on non-updated system
_mbedtlsver=2.28
_pythonver=3.10
depends=(
"jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils" "qt6-svg"
+ "mbedtls>=$_mbedtlsver"
- # "libxinerama" "provided by "vlc-luajit"
+ # "libxinerama" provided by "vlc-luajit"
# "libxkbcommon-x11" provided by "qt6-base"
# "jansson" "curl" provided by "ftl-sdk"
@@ -33,16 +33,8 @@ depends=(
"libxss" "libxrandr" "nss" "at-spi2-core"
# AUR Packages
- "ffmpeg-obs>=5" "vlc-luajit" "ftl-sdk"
+ "ffmpeg-obs>=6" "vlc-luajit" "ftl-sdk"
)
-# To manage mbedtls rebuild easily, this will prevent you to rebuild OBS on non-updated system
-# For Manjaro user this feature is disabled
-# Also OBS will need a patch when mbedtls 3 is on the repo
-if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
- depends+=('mbedtls')
-else
- depends+=("mbedtls>=$_mbedtlsver")
-fi
## About vlc-luajit
# The official VLC package will make OBS crash when a VLC source is used.
# The issue is that VLC and OBS are compiled with different lua version.
@@ -52,7 +44,8 @@ fi
## About ffmpeg-obs
# Read ffmpeg-obs PKGBUILD for more info
makedepends=(
- "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio" "lsb-release"
+ "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio"
+ "python>=$_pythonver"
# Needed by obs-websocket
'asio' 'nlohmann-json' 'websocketpp'
@@ -60,13 +53,6 @@ makedepends=(
# AUR Packages
"libajantv2"
)
-# To manage python rebuild easily, this will prevent you to rebuild OBS on non-updated system
-# For Manjaro user this feature is disabled
-if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
- makedepends+=('python')
-else
- makedepends+=("python>=$_pythonver")
-fi
optdepends=(
"libfdk-aac: FDK AAC codec support"
"intel-media-driver: Hardware encoding (>= Broadwell)"
@@ -74,17 +60,11 @@ optdepends=(
"libva-mesa-driver: Hardware encoding"
"swig: Scripting"
"luajit: Lua scripting"
+ "python>=$_pythonver: Python scripting"
"sndio: Sndio input client"
"v4l2loopback-dkms: Virtual camera output"
"libajantv2: AJA NTV 2 support"
)
-# To manage python rebuild easily, this will prevent you to rebuild OBS on non-updated system
-# For Manjaro user this feature is disabled
-if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
- optdepends+=("python: Python scripting")
-else
- optdepends+=("python>=$_pythonver: Python scripting")
-fi
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket")
conflicts=(
"obs-studio" "obs-vst" "obs-websocket"
@@ -104,17 +84,6 @@ sha256sums=(
"SKIP"
)
-if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
-source+=(
- "$pkgname.hook"
- "$pkgname.sh"
-)
-sha256sums+=(
- "2313f237e80b5160c5716e30cd7ac0a6a51c09a7ec83485ee33362de6e390009"
- "72b6aca44bfdc854b68c101c3304b927fa2411d6c05567f07252b335617d917d"
-)
-fi
-
if [[ $CARCH == 'x86_64' ]]; then
optdepends+=("decklink: Blackmagic Design DeckLink support")
fi
@@ -137,6 +106,8 @@ prepare() {
git config submodule.plugins/obs-websocket.url $srcdir/obs-websocket
git -c protocol.file.allow=always submodule update
+ git cherry-pick -n 2e79d4c902abf3e6bb4ad1b5bf779c0cc22a6fd0
+
cd plugins/obs-websocket
sed -i 's|EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/json/CMakeLists.txt||' CMakeLists.txt
sed -i 's|AND EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/deps/websocketpp/CMakeLists.txt||' CMakeLists.txt
@@ -175,9 +146,4 @@ package() {
cd obs-studio/build
make install DESTDIR="$pkgdir"
-
- if [[ $DISTRIB_ID == 'ManjaroLinux' ]]; then
- install -D -m644 "$srcdir/$pkgname.hook" -t "${pkgdir}"/usr/share/libalpm/hooks/
- install -D -m755 "$srcdir/$pkgname.sh" -t "${pkgdir}"/usr/share/libalpm/scripts/
- fi
}
diff --git a/obs-studio-rc.hook b/obs-studio-rc.hook
deleted file mode 100644
index b07cc9106563..000000000000
--- a/obs-studio-rc.hook
+++ /dev/null
@@ -1,10 +0,0 @@
-[Trigger]
-Type = Package
-Operation = Install
-Operation = Upgrade
-Target = obs-studio-rc
-
-[Action]
-Description = Warn Manjaro user about rebuild
-When = PostTransaction
-Exec = /usr/share/libalpm/scripts/obs-studio-rc.sh
diff --git a/obs-studio-rc.sh b/obs-studio-rc.sh
deleted file mode 100755
index 5e5dd7b3297b..000000000000
--- a/obs-studio-rc.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/bash
-
-msg() {
-ALL_OFF="\\e[1;0m"
-BOLD="\\e[1;1m"
-GREEN="${BOLD}\\e[1;32m"
-local mesg=$1; shift
-printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}" "$@" >&2
-}
-
-echo
-msg "Warning:
- -> obs-studio-rc does not support Manjaro
- -> officially.
- -> Some dependency version checks are disabled to
- -> allow the package to be built on it.
- -> So the package may require to be rebuilt if some
- -> dependency packages are updated. If not the
- -> package could not work correctly.
-"