summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-04-26 12:04:05 +0200
committertytan6522023-04-26 12:04:05 +0200
commitf5f34952c02a59b070bc86d40413891a330fbe5e (patch)
treee94f2cda2cc4fd9e599d487828f96811aafbf265
parent887b42c56adb48b4a3b2215137c6bd965ef9b1d8 (diff)
downloadaur-f5f34952c02a59b070bc86d40413891a330fbe5e.tar.gz
build: Update to 29.1-rc1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0fde2f6fcf0..a7e1334a38f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = obs-studio-rc
pkgdesc = Beta cycle of the free and open source software for video recording and live streaming. With everything except service integration
- pkgver = 29.1.0_beta4
+ pkgver = 29.1.0_rc1
pkgrel = 1
epoch = 5
url = https://github.com/obsproject/obs-studio
@@ -48,7 +48,7 @@ pkgbase = obs-studio-rc
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = libajantv2: AJA NTV 2 support
optdepends = decklink: Blackmagic Design DeckLink support
- provides = obs-studio=29.1.0_beta4
+ provides = obs-studio=29.1.0_rc1
provides = obs-vst
provides = obs-websocket
conflicts = obs-studio
@@ -58,7 +58,7 @@ pkgbase = obs-studio-rc
conflicts = obs-linuxbrowser
conflicts = libva-vdpau-driver
options = debug
- source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.0-beta4
+ source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.0-rc1
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
diff --git a/PKGBUILD b/PKGBUILD
index b180a11acea2..5e770392301e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
pkgname=obs-studio-rc
-_pkgver=29.1.0-beta4
+_pkgver=29.1.0-rc1
pkgver=${_pkgver//-/_}
pkgrel=1
epoch=5
@@ -107,7 +107,7 @@ build() {
mkdir -p build; cd build
cmake \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DENABLE_RTMPS=ON \
@@ -117,9 +117,9 @@ build() {
-DENABLE_SNDIO=ON \
-DENABLE_BROWSER=ON \
-DCEF_ROOT_DIR=/opt/cef-obs \
- -DBETA="$_pkgver" ..
+ -DRELEASE_CANDIDATE="$_pkgver" ..
# -DOBS_VERSION_OVERRIDE="$_pkgver" ..
-# -DRELEASE_CANDIDATE="$_pkgver" ..
+# -DBETA="$_pkgver" ..
sed -i "s|#define OBS_VERSION |#define OBS_VERSION \"$_pkgver-rc-$pkgrel\" //|" config/obsconfig.h