summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-09 20:32:31 +0200
committertytan6522023-05-09 20:32:31 +0200
commit251d52556208af2f2bbe6b560d71df3bb55d3c79 (patch)
treed1a1a6605e9997d357d4b037d817ab0f881d6c7a
parent46999855771b7d3d9dd80d833ec869273ec6c791 (diff)
downloadaur-251d52556208af2f2bbe6b560d71df3bb55d3c79.tar.gz
build: Update to 29.1.1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch53
-rw-r--r--PKGBUILD8
3 files changed, 6 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c4f990a8a5a..f495f42558b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
- pkgver = 29.1.0
- pkgrel = 3
+ pkgver = 29.1.1
+ pkgrel = 1
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
@@ -47,7 +47,7 @@ pkgbase = obs-studio-tytan652
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = libajantv2: AJA NTV 2 support
optdepends = decklink: Blackmagic Design DeckLink support
- provides = obs-studio=29.1.0
+ provides = obs-studio=29.1.1
provides = obs-vst
provides = obs-websocket
provides = obs-browser
@@ -58,19 +58,17 @@ pkgbase = obs-studio-tytan652
conflicts = obs-linuxbrowser
conflicts = libva-vdpau-driver
options = debug
- source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.0
+ source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.1.1
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
source = bind_iface.patch
source = v4l2_by-path.patch
- source = 0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 65116d10f03d390505fdb0bbf6fe649e8649500441dde91e029f2eb79bfdc80f
sha256sums = ee54b9c6f7e17fcc62c6afc094e65f18b2e97963c2fe92289b2b91972ac206e5
- sha256sums = 9227a5f3439d19c2c75e369bc6701dc83c4ac54cc371b7f74e55c9e275512f6c
pkgname = obs-studio-tytan652
diff --git a/0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch b/0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch
deleted file mode 100644
index dbb9d4c9f0e2..000000000000
--- a/0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 6acef4edf8ec353313f84103162c3064ecd2efb6 Mon Sep 17 00:00:00 2001
-From: tytan652 <tytan652@tytanium.xyz>
-Date: Thu, 4 May 2023 11:07:52 +0200
-Subject: [PATCH] cmake: Enforce -Wmaybe-uninitialized to never turn into an
- error
-
----
- cmake/Modules/CompilerConfig.cmake | 23 ++++++++++++-----------
- 1 file changed, 12 insertions(+), 11 deletions(-)
-
-diff --git a/cmake/Modules/CompilerConfig.cmake b/cmake/Modules/CompilerConfig.cmake
-index 41c56da8b4cee..849d19de75ccf 100644
---- a/cmake/Modules/CompilerConfig.cmake
-+++ b/cmake/Modules/CompilerConfig.cmake
-@@ -100,6 +100,13 @@ else()
- endif()
-
- option(CALM_DEPRECATION "Keep deprecated-declarations as warnings" OFF)
-+ #[[
-+ Note about -Wmaybe-uninitialized on GCC, this warning seems to be subject of various regressions and false positives. This
-+ warning is set to not turn into an error.
-+
-+ - https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105562 for 12.1.0
-+ - https://github.com/obsproject/obs-studio/issues/8850 for 13.1.1
-+ ]]
- add_compile_options(
- -Werror
- -Wextra
-@@ -117,19 +124,13 @@ else()
- "$<$<CONFIG:DEBUG>:-DDEBUG=1;-D_DEBUG=1>"
- "$<$<COMPILE_LANG_AND_ID:CXX,AppleClang,Clang>:-Wnull-conversion;-fcolor-diagnostics;-Wno-error=shorten-64-to-32>"
- "$<$<COMPILE_LANG_AND_ID:C,AppleClang,Clang>:-Wnull-conversion;-fcolor-diagnostics;-Wno-error=shorten-64-to-32>"
-- "$<$<COMPILE_LANG_AND_ID:CXX,GNU>:-Wconversion-null>"
-+ "$<$<COMPILE_LANG_AND_ID:CXX,GNU>:-Wconversion-null;-Wno-error=maybe-uninitialized>"
-+ "$<$<COMPILE_LANG_AND_ID:C,GNU>:-Wno-error=maybe-uninitialized>"
- "$<$<BOOL:${CALM_DEPRECATION}>:-Wno-error=deprecated-declarations>")
-
-- if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
-- # GCC on aarch64 emits type-limits warnings that do not appear on x86_64
-- if(CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
-- add_compile_options(-Wno-error=type-limits)
-- endif()
--
-- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=105562
-- if(CMAKE_CXX_COMPILER_VERSION VERSION_EQUAL "12.1.0")
-- add_compile_options(-Wno-error=maybe-uninitialized)
-- endif()
-+ # GCC on aarch64 emits type-limits warnings that do not appear on x86_64
-+ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_SYSTEM_PROCESSOR STREQUAL "aarch64")
-+ add_compile_options(-Wno-error=type-limits)
- endif()
-
- if(OBS_CODESIGN_LINKER)
diff --git a/PKGBUILD b/PKGBUILD
index 52fa02cf9dc0..cb205166889f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: tytan652 <tytan652 at tytanium dot xyz>
pkgname=obs-studio-tytan652
-pkgver=29.1.0
-pkgrel=3
+pkgver=29.1.1
+pkgrel=1
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -79,7 +79,6 @@ source=(
"qr::git+https://github.com/nayuki/QR-Code-generator.git"
"bind_iface.patch" # Based on https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch
"v4l2_by-path.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3437.patch
- "0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch"
)
sha256sums=(
"SKIP"
@@ -88,7 +87,6 @@ sha256sums=(
"SKIP"
"65116d10f03d390505fdb0bbf6fe649e8649500441dde91e029f2eb79bfdc80f"
"ee54b9c6f7e17fcc62c6afc094e65f18b2e97963c2fe92289b2b91972ac206e5"
- "9227a5f3439d19c2c75e369bc6701dc83c4ac54cc371b7f74e55c9e275512f6c"
)
if [[ $CARCH == 'x86_64' ]]; then
@@ -106,8 +104,6 @@ prepare() {
git -c protocol.file.allow=always submodule update deps/qr
cd "$srcdir/obs-studio"
- patch -Np1 < "$srcdir/0001-Enforce_-Wmaybe-uninitialized_never_turn_into_error.patch"
-
## Add network interface binding for RTMP on Linux (https://github.com/obsproject/obs-studio/pull/4219)
patch -Np1 < "$srcdir/bind_iface.patch"