summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-01-13 08:36:25 +0100
committertytan6522023-01-13 08:46:37 +0100
commit3e0c56b4981445f11b3f24008785596ea6983a9c (patch)
tree307a441df3fa5090fcd891a6ddf1ab4fca3823dc
parent5acf5d1fa71b26bbf3118f6f55b6b22724eb617e (diff)
downloadaur-3e0c56b4981445f11b3f24008785596ea6983a9c.tar.gz
build: Make the package conflict with libva-vdpau-driver
This is not an issue on OBS side but the driver's.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4431e3cad2a0..cd11745d8a25 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
pkgver = 29.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
@@ -55,8 +55,9 @@ pkgbase = obs-studio-tytan652
conflicts = obs-studio
conflicts = obs-vst
conflicts = obs-websocket
- conflicts = obs-linuxbrowser
+ conflicts = libva-vdpau-driver
conflicts = obs-browser
+ conflicts = obs-linuxbrowser
options = debug
source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=29.0.0
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
diff --git a/PKGBUILD b/PKGBUILD
index d869fe2b8004..541706868812 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-tytan652
pkgver=29.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -84,7 +84,10 @@ else
optdepends+=("python>=$_pythonver: Python scripting")
fi
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket")
-conflicts=("obs-studio" "obs-vst" "obs-websocket")
+conflicts=(
+ "obs-studio" "obs-vst" "obs-websocket"
+ "libva-vdpau-driver" # This driver is abandonned and make OBS segfault if it happen to be loaded, try libva-nvidia-driver is you really need Nvidia decode through VAAPI
+)
options=('debug')
source=(
"obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
@@ -121,7 +124,10 @@ fi
if [[ $CARCH == 'x86_64' ]]; then
makedepends+=("cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1")
provides+=("obs-browser")
- conflicts+=("obs-linuxbrowser" "obs-browser")
+ conflicts+=(
+ "obs-browser"
+ "obs-linuxbrowser" # This plugin is obsolete
+ )
_browser=ON
else
_browser=OFF