summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-05-04 17:03:25 +0200
committertytan6522021-05-04 17:03:25 +0200
commit419555392ffe9a1cf5f78f24fff79a00fbddb880 (patch)
treea51cf2dddb27d91666b5b98fe8ce508bdd47457d
parenta7ac3abe226cc7d5e37277017bf6abc5704ecc02 (diff)
downloadaur-419555392ffe9a1cf5f78f24fff79a00fbddb880.tar.gz
build: add python scripting
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17b8573e0959..f0d00f098be8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
- pkgdesc = Free and open source software for video recording and live streaming. Built with Browser, VST plugins and my bind interface PR. No FTL and Python
+ pkgdesc = Free and open source software for video recording and live streaming. Built with Browser, VST plugins and my bind interface PR. No FTL
pkgver = 26.1.2
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = obs-studio-tytan652
makedepends = vlc
makedepends = swig
makedepends = luajit
+ makedepends = python
depends = ffmpeg
depends = jansson
depends = libxinerama
@@ -31,20 +32,21 @@ pkgbase = obs-studio-tytan652
optdepends = vlc: VLC Media Source
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
+ optdepends = python: scripting support
optdepends = v4l2loopback-dkms: Virtual camera output
provides = obs-studio=26.1.2
conflicts = obs-studio
conflicts = obs-linuxbrowser
- source = obs-studio-tytan652::git+https://github.com/obsproject/obs-studio.git#tag=26.1.2
+ source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=26.1.2
source = bind_iface.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch
- source = git+https://github.com/obsproject/obs-browser.git
- source = git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8
- source = VST_PATH_fix.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-vst/pull/82.patch
+ source = python_fix.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3335.patch
+ source = obs-browser::git+https://github.com/obsproject/obs-browser.git
+ source = obs-vst::git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 4ee347b12a9cc93bad2357a2ba29341a846da7e0ff80a3bf3e88c3b661643595
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 169af464164ef05384586f31fbde3d509159976e0afb914907fb3cf395adaf6e
source_i686 = https://cef-builds.spotifycdn.com/cef_binary_76.1.13+gf19c584+chromium-76.0.3809.132_linux32_minimal.tar.bz2
sha256sums_i686 = baa0624e2d6b86a60d18117cb65e125f882ef66cf413cd7ac63a480d904004f0
source_x86_64 = https://cef-builds.spotifycdn.com/cef_binary_76.1.13+gf19c584+chromium-76.0.3809.132_linux64_minimal.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index b37e96f94e5b..2ed5ae0f08da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ pkgname=obs-studio-tytan652
# Use same CEF as obs project PPA
_cefname=cef_binary_76.1.13+gf19c584+chromium-76.0.3809.132
pkgver=26.1.2
-pkgrel=5
-pkgdesc="Free and open source software for video recording and live streaming. Built with Browser, VST plugins and my bind interface PR. No FTL and Python"
+pkgrel=6
+pkgdesc="Free and open source software for video recording and live streaming. Built with Browser, VST plugins and my bind interface PR. No FTL"
# Why no FTL ? Because Mixer is dead
# Why no Python ? Because it doesn't work out of the box with Python 3.9
arch=("i686" "x86_64")
@@ -13,7 +13,7 @@ license=("GPL2")
depends=("ffmpeg" "jansson" "libxinerama" "libxkbcommon-x11" "mbedtls"
"qt5-svg" "qt5-x11extras" "curl" "jack" "gtk-update-icon-cache")
makedepends=("cmake" "git" "libfdk-aac" "libxcomposite" "x264"
- "vlc" "swig" "luajit")
+ "vlc" "swig" "luajit" 'python')
optdepends=(
"libfdk-aac: FDK AAC codec support"
"libxcomposite: XComposite capture support"
@@ -22,25 +22,26 @@ optdepends=(
"vlc: VLC Media Source"
"swig: Scripting"
"luajit: Lua scripting"
+ "python: scripting support"
"v4l2loopback-dkms: Virtual camera output"
)
provides=("obs-studio=$pkgver")
conflicts=("obs-studio" "obs-linuxbrowser")
source=(
- "$pkgname::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
+ "obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"bind_iface.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch"
- "git+https://github.com/obsproject/obs-browser.git"
- "git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8"
- "VST_PATH_fix.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-vst/pull/82.patch"
+ "python_fix.patch::https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3335.patch"
+ "obs-browser::git+https://github.com/obsproject/obs-browser.git"
+ "obs-vst::git+https://github.com/obsproject/obs-vst.git#commit=cca219fa3613dbc65de676ab7ba29e76865fa6f8"
)
source_x86_64=("https://cef-builds.spotifycdn.com/${_cefname}_linux64_minimal.tar.bz2")
source_i686=("https://cef-builds.spotifycdn.com/${_cefname}_linux32_minimal.tar.bz2")
sha256sums=(
"SKIP"
- "4ee347b12a9cc93bad2357a2ba29341a846da7e0ff80a3bf3e88c3b661643595"
"SKIP"
"SKIP"
- "169af464164ef05384586f31fbde3d509159976e0afb914907fb3cf395adaf6e"
+ "SKIP"
+ "SKIP"
)
sha256sums_x86_64=("6b0dfa8ddafcec822fcd20018cf081959ffa6d0565be3793da1f596ac0733c38")
sha256sums_i686=("baa0624e2d6b86a60d18117cb65e125f882ef66cf413cd7ac63a480d904004f0")
@@ -66,11 +67,13 @@ prepare() {
# Fix CEF read permissions
chmod 644 libcef_dll_wrapper/libcef_dll_wrapper.a
- cd "$srcdir/$pkgname"
+ cd "$srcdir/obs-studio"
git config submodule.plugins/obs-browser.url $srcdir/obs-browser
git submodule update
# Add network interface binding for RTMP on Linux (https://github.com/obsproject/obs-studio/pull/4219)
patch -Np1 < "$srcdir/bind_iface.patch"
+ # libobs/util: Fix loading Python binary modules on *nix (https://github.com/obsproject/obs-studio/pull/3335)
+ patch -Np1 < "$srcdir/python_fix.patch"
cd plugins
# Replace obs-vst submodule by the repo with same last commit. Will be reverted when 27 is out.
@@ -80,19 +83,18 @@ prepare() {
cd obs-vst
# obs-vst: fix memory leak
git cherry-pick -n 944c1c962748ee48ab0eca24bacc5354c169eb60
- # Fix VST_PATH use under Linux (https://github.com/obsproject/obs-vst/pull/82)
- patch -Np1 < "$srcdir/VST_PATH_fix.patch"
+ # obs-vst: Fix VST_PATH use under Linux
+ git cherry-pick -n f34327d98c0a54a6da29d37f0b8db790b6adbe4e
}
build() {
- cd $pkgname
+ cd obs-studio
mkdir -p build; cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DDISABLE_PYTHON=ON \
-DBUILD_BROWSER=$CEF \
-DCEF_ROOT_DIR="$srcdir/${_cefname}_linux${CEF_ARCH}_minimal" \
-DOBS_VERSION_OVERRIDE=$pkgver ..
@@ -101,7 +103,7 @@ build() {
}
package() {
- cd $pkgname/build
+ cd obs-studio/build
make install DESTDIR="$pkgdir"
}