summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522021-12-29 10:27:41 +0100
committertytan6522021-12-29 10:27:41 +0100
commit560c887ec971a3174ab44bbde345dd30ff6e159f (patch)
treed154b5e909098d68f71b9534faf44eaf98baac20
parent2c1476e3b4badb8336aa0f7d22e5b35d712c7f40 (diff)
downloadaur-560c887ec971a3174ab44bbde345dd30ff6e159f.tar.gz
build: mbedtls 2.28 rebuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 595814fee3fe..ce67e6395563 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes.
pkgver = 27.1.3
- pkgrel = 10
+ pkgrel = 11
url = https://github.com/obsproject/obs-studio
arch = i686
arch = x86_64
@@ -12,15 +12,16 @@ pkgbase = obs-studio-tytan652
makedepends = libfdk-aac
makedepends = swig
makedepends = luajit
- makedepends = python
makedepends = sndio
+ makedepends = python>=3.10
makedepends = cef-minimal-obs=87.1.14
- depends = mbedtls
depends = jack
depends = gtk-update-icon-cache
depends = x264
depends = rnnoise
depends = pciutils
+ depends = mbedtls>=2.28
+ depends = mbedtls<3.0.0
depends = qt5-wayland
depends = libxcomposite
depends = pipewire
@@ -38,7 +39,7 @@ pkgbase = obs-studio-tytan652
optdepends = libva-mesa-driver: Hardware encoding
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
- optdepends = python: Python scripting
+ optdepends = python>=3.10: Python scripting
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = decklink: Blackmagic Design DeckLink support
diff --git a/PKGBUILD b/PKGBUILD
index 07d14af8bcec..8a2fba433420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,19 @@
pkgname=obs-studio-tytan652
pkgver=27.1.3
-pkgrel=10
+pkgrel=11
pkgdesc="Free and open source software for video recording and live streaming. With Browser dock and sources, VST 2 filter, FTL protocol, VLC sources, V4L2 devices by paths, my bind interface PR, and sometimes backported fixes."
arch=("i686" "x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL2")
+_mbedtlsver=2.28
+_pythonver=3.10
depends=(
- "mbedtls" "jack" "gtk-update-icon-cache" "x264" "rnnoise"
- "pciutils"
+ "jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils"
+
+ # To manage mbedtls rebuild easily, this will prevent you to rebuild OBS on non-updated system
+ # Also OBS will need a patch when mbedtls 3 is on the repo
+ "mbedtls>=$_mbedtlsver" "mbedtls<3.0.0"
# "libxinerama" "qt5-svg" provided by "vlc-luajit"
# "libxkbcommon-x11" provided by "qt5-base"
@@ -39,8 +44,11 @@ depends=(
## About ffmpeg-obs
# Read ffmpeg-obs PKGBUILD for more info
makedepends=(
- "cmake" "git" "libfdk-aac" "swig" "luajit" "python"
- "sndio"
+ "cmake" "git" "libfdk-aac" "swig" "luajit" "sndio"
+
+ # To manage python rebuild easily, this will prevent you to rebuild OBS on non-updated system
+ "python>=$_pythonver"
+
# AUR Packages
"cef-minimal-obs=87.1.14"
)
@@ -51,7 +59,7 @@ optdepends=(
"libva-mesa-driver: Hardware encoding"
"swig: Scripting"
"luajit: Lua scripting"
- "python: Python scripting"
+ "python>=$_pythonver: Python scripting"
"sndio: Sndio input client"
"v4l2loopback-dkms: Virtual camera output"
#"libajantv2: AJA NTV 2 support"