summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522023-05-04 10:16:20 +0200
committertytan6522023-05-04 10:16:20 +0200
commit7cff869aa07c8ee12f4553107adb1b27fd1d0e6f (patch)
treeb58f7d59cc6056c059b9a41ae045be81c2531eb8
parenta50a7eeecfab41dcbaab12381b2c5175007b77d9 (diff)
downloadaur-7cff869aa07c8ee12f4553107adb1b27fd1d0e6f.tar.gz
build: GCC 13 and Python 3.11
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix_build_with_GCC_13.patch36
-rw-r--r--PKGBUILD8
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6766e424fed..88a956455e49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
pkgver = 29.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
@@ -12,7 +12,7 @@ pkgbase = obs-studio-tytan652
makedepends = swig
makedepends = luajit
makedepends = sndio
- makedepends = python>=3.10
+ makedepends = python>=3.11
makedepends = asio
makedepends = nlohmann-json
makedepends = websocketpp
@@ -42,7 +42,7 @@ pkgbase = obs-studio-tytan652
optdepends = libva-mesa-driver: Hardware encoding
optdepends = swig: Scripting
optdepends = luajit: Lua scripting
- optdepends = python>=3.10: Python scripting
+ optdepends = python>=3.11: Python scripting
optdepends = sndio: Sndio input client
optdepends = v4l2loopback-dkms: Virtual camera output
optdepends = libajantv2: AJA NTV 2 support
@@ -64,11 +64,13 @@ pkgbase = obs-studio-tytan652
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
source = bind_iface.patch
source = v4l2_by-path.patch
+ source = 0001-Fix_build_with_GCC_13.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 65116d10f03d390505fdb0bbf6fe649e8649500441dde91e029f2eb79bfdc80f
sha256sums = ee54b9c6f7e17fcc62c6afc094e65f18b2e97963c2fe92289b2b91972ac206e5
+ sha256sums = 450cbf6df2b14ec8f9c43c1c7d44b06ab1b10c38eae6d1048eebffb4ca16e569
pkgname = obs-studio-tytan652
diff --git a/0001-Fix_build_with_GCC_13.patch b/0001-Fix_build_with_GCC_13.patch
new file mode 100644
index 000000000000..f1b60602b0e6
--- /dev/null
+++ b/0001-Fix_build_with_GCC_13.patch
@@ -0,0 +1,36 @@
+From 16aa55071f29c9e90d7b08ddd2e61fb6d5561f15 Mon Sep 17 00:00:00 2001
+From: tytan652 <tytan652@tytanium.xyz>
+Date: Thu, 4 May 2023 09:57:19 +0200
+Subject: [PATCH] obs-ffmpeg,obs-outputs: Fix maybe-unintialized warnings on
+ GCC 13
+
+---
+ plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c | 2 +-
+ plugins/obs-outputs/librtmp/rtmp.c | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
+index a3c4f925c607d..c454410a76295 100644
+--- a/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
++++ b/plugins/obs-ffmpeg/ffmpeg-mux/ffmpeg-mux.c
+@@ -727,7 +727,7 @@ static void *ffmpeg_mux_io_thread(void *data)
+ // ffmpeg, then we flush the chunk. next_seek_position is the actual
+ // offset we should seek to when we write the chunk.
+ uint64_t current_seek_position = 0;
+- uint64_t next_seek_position;
++ uint64_t next_seek_position = 0;
+
+ for (;;) {
+ // Wait for ffmpeg to write data to the buffer
+diff --git a/plugins/obs-outputs/librtmp/rtmp.c b/plugins/obs-outputs/librtmp/rtmp.c
+index 28239cb0351c8..7d0e6db7e0594 100644
+--- a/plugins/obs-outputs/librtmp/rtmp.c
++++ b/plugins/obs-outputs/librtmp/rtmp.c
+@@ -4556,6 +4556,7 @@ DecodeTEA(AVal *key, AVal *text)
+ /* prep text: hex2bin, multiples of 4 */
+ n = (text->av_len + 7) / 8;
+ out = malloc(n * 8);
++ memset(out, 0, n * 8);
+ ptr = (unsigned char *)text->av_val;
+ v = (uint32_t *) out;
+ for (i = 0; i < n; i++)
diff --git a/PKGBUILD b/PKGBUILD
index 3864b57468e8..821cdf6675d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=obs-studio-tytan652
pkgver=29.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
license=("GPL3")
# To manage dependency rebuild easily, this will prevent you to rebuild OBS on non-updated system
_mbedtlsver=2.28
-_pythonver=3.10
+_pythonver=3.11
depends=(
"jack" "gtk-update-icon-cache" "x264" "rnnoise" "pciutils" "qt6-svg"
"mbedtls>=$_mbedtlsver"
@@ -79,6 +79,7 @@ source=(
"qr::git+https://github.com/nayuki/QR-Code-generator.git"
"bind_iface.patch" # Based on https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/4219.patch
"v4l2_by-path.patch" # https://patch-diff.githubusercontent.com/raw/obsproject/obs-studio/pull/3437.patch
+ "0001-Fix_build_with_GCC_13.patch"
)
sha256sums=(
"SKIP"
@@ -87,6 +88,7 @@ sha256sums=(
"SKIP"
"65116d10f03d390505fdb0bbf6fe649e8649500441dde91e029f2eb79bfdc80f"
"ee54b9c6f7e17fcc62c6afc094e65f18b2e97963c2fe92289b2b91972ac206e5"
+ "450cbf6df2b14ec8f9c43c1c7d44b06ab1b10c38eae6d1048eebffb4ca16e569"
)
if [[ $CARCH == 'x86_64' ]]; then
@@ -104,6 +106,8 @@ prepare() {
git -c protocol.file.allow=always submodule update deps/qr
cd "$srcdir/obs-studio"
+ patch -Np1 < "$srcdir/0001-Fix_build_with_GCC_13.patch"
+
## Add network interface binding for RTMP on Linux (https://github.com/obsproject/obs-studio/pull/4219)
patch -Np1 < "$srcdir/bind_iface.patch"