summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortytan6522022-09-07 12:02:11 +0200
committertytan6522022-09-07 12:02:11 +0200
commit91b545dc52014ab2cc23659669ab62201a71b43e (patch)
tree0011ea3373471f931517f18714bcf24e7f5b5851
parent155513c8eea65e0e48ef997a1ccb631a6b1a4d49 (diff)
downloadaur-91b545dc52014ab2cc23659669ab62201a71b43e.tar.gz
build: Re-use cef-minimal-obs package
I finally found the issue, revert the previous commit since doing that also fix the previous issue
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 7 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae4cb3fd2c1a..5d6c92ffb871 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = obs-studio-tytan652
pkgdesc = Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes
pkgver = 28.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/obsproject/obs-studio
arch = x86_64
arch = aarch64
@@ -18,6 +18,7 @@ pkgbase = obs-studio-tytan652
makedepends = websocketpp
makedepends = libajantv2
makedepends = python>=3.10
+ makedepends = cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1
depends = jack
depends = gtk-update-icon-cache
depends = x264
@@ -56,20 +57,18 @@ pkgbase = obs-studio-tytan652
conflicts = obs-websocket
conflicts = obs-linuxbrowser
conflicts = obs-browser
- options = !strip
+ options = debug
source = obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=28.0.1
source = obs-browser::git+https://github.com/obsproject/obs-browser.git
source = obs-websocket::git+https://github.com/obsproject/obs-websocket.git
source = qr::git+https://github.com/nayuki/QR-Code-generator.git
source = bind_iface.patch
source = v4l2_by-path.patch
- source = https://cdn-fastly.obsproject.com/downloads/cef_binary_5060_linux64.tar.bz2
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = a244f5b594ed7f0b215a0c0fb0bee445cbb5726b12fdfe539e70f0d9d991dab9
sha256sums = ee54b9c6f7e17fcc62c6afc094e65f18b2e97963c2fe92289b2b91972ac206e5
- sha256sums = ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d
pkgname = obs-studio-tytan652
diff --git a/PKGBUILD b/PKGBUILD
index 8cee4770e57a..6252104bbb17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DISTRIB_ID=`lsb_release --id | cut -f2 -d$'\t'`
pkgname=obs-studio-tytan652
pkgver=28.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Free and open source software for video recording and live streaming. With everything except service integrations. Plus V4L2 devices by paths, my bind interface PR, and sometimes backported fixes"
arch=("x86_64" "aarch64")
url="https://github.com/obsproject/obs-studio"
@@ -85,7 +85,7 @@ else
fi
provides=("obs-studio=$pkgver" "obs-vst" "obs-websocket")
conflicts=("obs-studio" "obs-vst" "obs-websocket")
-options=('!strip')
+options=('debug')
source=(
"obs-studio::git+https://github.com/obsproject/obs-studio.git#tag=$pkgver"
"obs-browser::git+https://github.com/obsproject/obs-browser.git"
@@ -119,14 +119,10 @@ if [[ $CARCH == 'x86_64' ]]; then
fi
if [[ $CARCH == 'x86_64' ]]; then
- _cefbranch=5060
- source+=("https://cdn-fastly.obsproject.com/downloads/cef_binary_${_cefbranch}_linux64.tar.bz2")
- sha256sums+=("ac4e2a8ebf20700e4e36353e314f876623633dd5b474778a2548bb66bdbea11d")
+ makedepends+=("cef-minimal-obs=103.0.0_5060_shared_textures_143.2591+g4204d54+chromium_103.0.5060.134_1")
provides+=("obs-browser")
conflicts+=("obs-linuxbrowser" "obs-browser")
_browser=ON
- _arch=64
- _parch=x86_64
else
_browser=OFF
fi
@@ -155,17 +151,6 @@ prepare() {
}
build() {
- if [[ $CARCH == 'x86_64' ]]; then
- cd "$srcdir"/cef_binary_${_cefbranch}_linux${_arch}
-
- #The arm64 CEF set the wrong arch for the project
- cmake \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DPROJECT_ARCH=$_parch .
-
- make libcef_dll_wrapper
- fi
-
cd "$srcdir"/obs-studio
mkdir -p build; cd build
@@ -179,7 +164,7 @@ build() {
-DENABLE_JACK=ON \
-DENABLE_SNDIO=ON \
-DENABLE_BROWSER=$_browser \
- -DCEF_ROOT_DIR="$srcdir/cef_binary_${_cefbranch}_linux${_arch}" \
+ -DCEF_ROOT_DIR=/opt/cef-obs \
-DOBS_VERSION_OVERRIDE="$pkgver-tytan652-$pkgrel" ..
make